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About This Manual 
This manual is intended as a help for the system designer to get started with the creation of a project. It 
contains the following information: 

• An introduction to the IGSS system and its components (Chapter 1) 
• Step-by-step procedures for creating a new project from scratch (Chapter 2) 
• Descriptions of the key object types and terminology used in IGSS (Chapter 3) 

The manual deals almost exclusively with the Definition module. For information about the other modules 
in the IGSS system, refer to the Help function. 
The manual is NOT a reference manual. The built-in Help function should be used for finding further 
details about the topics covered in this manual. References to the Help function are given throughout the 
manual. 
 
This manual contains the following chapters: 
 

This chapter … contains the following: 

1: Welcome to 
IGSS 

an introduction to IGSS and an overview of its components. 

2: Creating a 
project 

step-by-step procedures for creating a project. The sample project is 
very small and simple but all the important system types are 
represented. 

3: Types and 
Templates 

definition and use of each of the IGSS types: area, diagram, graph, 
analog, table, counter, digital, string and scaling, including an 
explanation of the physical counterpart of each type. The chapter 
gives you a thorough understanding of the different object types and 
provides you with the terminology required for reading Chapter 3. 

 

 
The following typographical conventions are used: 
 

Item Convention Example 

User interface element Bold typeface The Edit Mapping tab. 

Menu structure Arrow between menu items To access Help, select Help 
→ Help Topics. 

User input Monospace typeface We have now inserted the 
following text: 
The level in the 
basin is too low. 
Pour faster … 

IGSS module Red bold typeface Open the Definition 
module. 

Reference to Help Italic typeface For further details about 
addressing, search for “PLC 
addresses” in the 
Definition Help file. 

 

  

Intended use 

Structure of this 
manual 

Conventions 
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IGSS User Documentation 
With the IGSS system you receive the following documentation items: 
 

This documentation 
item … 

includes the following … 

Getting Started See the “About This Manual” section. 

Igssmaster.chm Generel help on how to use the IGSS Master module and how 
to perform the fundamental tasks with IGSS. 

Igss module Help Step-by-step procedures, reference information and context-
sensitive help for the specific module you are currently 
working with.  

 

 
The figure below shows a typical window from the IGSS Help system: 

 
Figure 1 A typical window from the IGSS Help system. 

 
We have tried to design our Help so that you can easily distinguish the different types of information being 
presented. The most important types are: 
 

Topic Type Description 

Step-by-step procedure Includes numbered steps for performing a specific task. This 
type of topic is presented in a small card-like window in the 
upper right corner of the screen so that you can read the 
procedure and perform the task at hand at the same time. 

Reference information Describes user interface details or conceptual information. For 
example, there are topics describing the different object types. 

What’s This? Help Describes an individual item in a dialog,that is a button or a 
field. 

 
  

Documentation 
overview 

IGSS Help  

Types of Help 
topics 
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There are several ways to access Help dependent on what type of Help you want: 
 

To access this type of Help … do the following… 

Step-by-step procedure or 
reference information 

Select Help → Help Topics and find the requested topic 
on the Contents tab or search for it from the Index or 
Find tabs (see “Searching in Help” below). 

What’s This? Help In a dialog, do one of the following: 
• Click the  in the upper right corner, then click 

the item you want information about. 
• Move the focus to the desired item by pressing TAB, 

then press F1. 
 

 
Most often you will search for a specific piece of information in Help. The easiest way to do this is by using 
the built-in search facilities: 
 

Use the … when you are searching for … 

Index Step-by-step procedures, reference or conceptual information or user 
interface details. 

Search Specific words or phrases that you cannot find in the Index. 
 

The Help function also contains a Contents tab which provides a hierarchical view of the Help topics. 
 
If you are in doubt as to how to use the Help function, just press F1 to get Help.  
 
New updated Help files will be available for download on our Web site on www.igss.com. To get the help 
files the easy way use the IGSS Update module. In each Help file you will find a Version Information topic 
in the Reference Information book on the Contents tab. That topic tells you when the Help file was created 
and which software version it describes.  
 
IGSS now offer its users to access entire online help documentation with just a few clicks.  
You can find a help file for each IGSS module plus some additional thematic help-files. All help files are 
available on: www.igss.com/support/help-and-manuals. 
IGSS also provides training videos which helps you to get started with a project and gives you a basic 
knowledge about the program. IGSS training videos are available at: www.igss.com/training/scada-training-
videos. 
For a fast guide to IGSS, you can also download the IGSS Quick Start Guide as a pdf on the Web site. 
 

Accessing Help 

Searching in Help 

Help on Help 

Updated Help files 

Webhelp 

http://www.7t.dk/�
http://www.igss.com/support/help-and-manuals�
http://www.igss.com/training/scada-training-videos�
http://www.igss.com/training/scada-training-videos�
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Chapter 1:  Welcome to IGSS 

Overview 
 
This chapter gives you an introduction to the IGSS system. 
 
 
This chapter contains the following topics. 
What is IGSS? ....................................................................................................................... 7 
Overview of programs ........................................................................................................... 8 
 

What is IGSS? 
IGSS is a SCADA system used for monitoring and controlling industrial processes. Used in a wide range of 
industries, IGSS has sold more than 25,000 licenses since first coming on the market in 1984. 
 
IGSS is currently in operation in many different industries, including: 

• Food and Beverage  
• Oil and Gas  
• Education  
• Pharmaceutical & Health  
• Energy  
• Marine  
• Traffic  
• Wastewater Treatment  
• Water Supply 

Please visit our website to view the full reference list and application notes about running IGSS 
installations. 
 
IGSS V9.0 runs under Windows 7, Windows Vista and Windows XP.  
 
 
The system targets two types of users: 
• system designers who construct a model of the industrial plant and 
• operators who monitor and control the plant via PCs 
 
IGSS is a true object-oriented program. This results in several useful advantages for the system designer 
and the operator. Most importantly, a process component consisting of a number of I/O points is treated as 
one object in IGSS. This means that the system designer and the operator have the same perception of an 
object and that the properties of this object can be viewed and modified from one dialog box. Object types 
and templates are other object-oriented terms used in IGSS. Templates are especially useful to the system 
designer because he can define one template and then base any number of objects sharing identical 
properties on that template. 
 
Openness is a cornerstone in the IGSS architecture. 7-Technologies believe that our users want the freedom 
to use the newest technologies. Therefore IGSS supports a variety of standards and interfaces including 
ODBC, SQL, OPC, OLE, VBA/Automation and ActiveX. These interfaces allow you to exchange IGSS 
data with 3rd party programs. If you are about to create a huge project, you may want to define the process 
components in an external database and then import the data into IGSS. 
 

About this 
chapter 

Contents 

Introduction 

IGSS reference 
list 

Operating 
systems 
supported 

User types 

Object-orientation 

Data exchange 
interfaces 

Scalability 
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Scalability is another key feature of IGSS. Based on true client/server architecture, you can easily expand 
the number of operator stations or the number of objects in your project. If you have a distributed plant, you 
can even connect remote operator stations, if required. 

 
When you buy IGSS, you only purchase the number of objects, operator stations and communication 
drivers that you need. The system can be expanded at any time as your needs grow. 
Several redundancy solutions are also available to minimize system downtime. Please contact the IGSS 
Sales Department for further information. 
 
For a more detailed overview of system features, search for "key features and benefits" in the 
Igssmaster.chm file. 
 
For an overview of the new features in this version, search for "what's new in this version?" in the 
Igssmaster.chm file. 
 

Overview of modules 
 
IGSS consists of a number of modules each with its own specific purpose. The following list of modules is 
divided into the two main user types: System designers and operators. 
 
Some modules are not part of the standard version. In that case, it is noted against the module name. 
For further details about any of the modules, use its associated Help function. 
 

Module name Summary of use Module type 

 
Master 

Access all the IGSS modules and system 
tools. Change the system to Design mode or 
Runtime mode. 

Main module 

 
Definition 

Build a model of the physical process being 
monitored and connect to the PLC addresses 
of the physical process components. Prepare 
process diagrams for the operators.  

Setup module 

 
System 

Configuration 

Specify global settings for the system and set 
up the appropriate communication drivers to 
enable communication with the PLCs. 

Setup module 

 
Job Scheduler 

Schedule jobs for automatic execution at 
regular intervals or based on events.  

Utility 

 
Maintenance 

Create maintenance jobs which define a 
maintenance interval for specific process 
components. When the interval is exceeded, 
the operator gets a maintenance reminder. 

Utility 

 
User 

Administration 

Define user names and passwords, user 
groups and user privileges. 

Setup module 

Sales versions 

Further details 

What's new in  
this version 

Introduction 

System designer 
modules 
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Notifier 

Set up duty periods and calendars during 
which critical alarms will be sent to the 
mobile phones of the duty personnel. Specify 
commands which can be activated from 
operators mobile phones. 

Utility 

 
 

 
 

Module name Summary of use Module type 

 

 
Alarm 

 

Easily view alarms either directly on process 
diagrams, in the Alarm List (active alarms) or 
the Alarm Log (historical alarms). Handle 
alarms based on recommended operator action 
and document irregularities using operator 
notes. 

Main module 

 
Audit Trail 

Record all actions done by system operators. 
For a quick look at the Audit Trail help file 
click here. 

Utility 

 
Dashboard 

Create your own customized overview of 
process data from multiple processes - all in 
one view. For more information click here. 

Utility 

 
Maintenance 

Get maintenance reminders in the maintenance 
or alarm list and perform the related 
maintenance jobs. 

Utility 

 
Reports 

View or print reports. Two main types of 
reports are available:  

• standard reports (daily, weekly etc.) 
• custom reports (use MS Excel to 

create flexible report contents and 
layouts)  

Report module 

 
Supervise 

Monitor and control the plant. Alarm handling 
is an integrated part of Supervise. 

Main module 

 

 
 
 

Operator modules 
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Chapter 2:  How to Create a Project 

Overview 
 
This chapter contains the following information: 
• A presentation of the sample project we are going to build 
• Step-by-step procedures for setting up and preconfiguring the project 
• Step-by-step procedures for building the project and installing it 
• Step-by-step procedures for refining the project with some of the more advanced features in the system 
 
The sample project shows how you create objects of the different object types. The procedures describe the 
most basic and typical ways of defining these objects. 
If you are interested in more advanced ways of creating objects, refer to “Section D: Optional Design 
Procedures” in this chapter. 
 
This chapter contains the following sections. 
Section A: The Sample Project ............................................................................................11 
Section B: Setting Up and Preconfiguring ...........................................................................14 
Section C: Mandatory Design Procedures  ..........................................................................29 
Section D: Optional Design Procedures ...............................................................................68 
 

About this 
chapter 

About the project 

Contents 
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 Section A: The Sample Project 

Overview 
 
This section contains the following information: 
• A detailed presentation of the project we are going to build 
• A project checklist which will help us ensure that all the necessary steps are performed 
 
This section contains the following topics. 
 
The Project We Will Build .................................................................................................. 12 
The Project Checklist........................................................................................................... 13 
 

About this section 

Contents 
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The Project We Will Build 
 
In this chapter we will create a small IGSS project step by step. The project consists of a tank into which 
water is filled and let out. The project we aim to create looks like this: 

 
Figure 3.1 The sample project we are going to build. 

 
In order not to introduce too much complexity, the sample project is run on a single-user system. Once you 
are familiar with the basic project techniques, you can read more about setting up multi-user systems in the 
"Multi-User Systems" Help file in the “IGSS” program group. 
 
The project consists of the following components (or objects in IGSS terminology): 
 

Object name IGSS type Description 

Overview Diagram The diagram showing the project. We will use the built-in 
area called Global. 

F0147 Analog Measures the hourly flow of the water intake. 

L0147 Analog Displays the water level in the tank. 

C0147 Counter Counts the number of liters let into the tank per hour. 

T0147 Table Monitors the temperatures at different levels in the tank. 

V1 Digital Controls the water intake. 

V2 Digital Controls the water outlet. 

Fahren.toCel Scaling Converts temperature values from Celsius (°C) to 
Fahrenheit (°F). 

Message String Describes the current state of the process. In this example, 
the text “Now filling water into basin …” is shown. 

 

  

Introduction 

Single-user 
system 

The project 
components 
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The Project Checklist 
 
Before we start setting up and building the project, let’s take a look at the checklist which is divided into 
two phases: “Setting up and preconfiguring” and “Mandatory design procedures”. 
 
We will go through the following procedures: 
 

Procedure Mark when completed 

Create the new project  

Define IGSS station type  

Set up the station parameters  

Set up the driver parameters  

Make background drawings  

Plan alarm texts  

Draw new symbols  
 

 
We will go through the following procedures: 
 

Procedure Mark when completed 

Define areas and diagrams (Overview)  

Define scaling objects (Fahren.toCel) and 
templates (Valve) 

 

Define digital objects (V1 and V2)  

Define analog objects (F0147 and L0147)  

Define table objects (T0147)  

Define counter objects (C0147)  

Define string objects (Message)  

Define alarm texts  

Define graph windows (G0147)  

Simulate process values  

Install the project and troubleshoot  

Define operator reports  
 

 
Note that the sequence of the project process given above is merely a recommended order and is by no 
means compulsory. You can always go back to the previous procedure and make any modification you like. 
Also, some of the procedures may or can be repeated several times - this particularly goes for “Install the 
project and troubleshoot”, a procedure that you will typically repeat after each step in the “Building the 
project” phase. 
 

Introduction 

Setting up and 
preconfiguring 

Building the 
project 

Recommended 
order 
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Section B: Setting Up and Preconfiguring 

Overview 
 
This section takes you through the key properties in System Configuration. For information about the 
remaining functions and properties, refer to the System Configuration Help file. 
 
The System Configuration module is where you define the global settings for the IGSS system. 
 
 
Create the New Project and Set It Active .............................................................................15 
Define the IGSS Station Type ..............................................................................................16 
Set Up Global Parameters ....................................................................................................17 
Set Up Data Collection Parameters ......................................................................................18 
Set Up Alarm and Log Printers ............................................................................................23 
Define the Driver Setup .......................................................................................................24 
Make Background Drawings ...............................................................................................25 
Plan Alarm Texts .................................................................................................................26 
Draw New Symbols .............................................................................................................27 
Checklist Review - Setting Up and Preconfiguring .............................................................28 
  

About this section 

About System 
Configuration 

Contents 
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Create the New Project Using the New Project Wizard and Set It Active 
 
The very first thing you must do is to create a new project and give it a descriptive name. We will name our 
sample project, Getting Started. 
 

Step Action 

1. Start IGSS Master. 
Select Start → Programs → IGSS 9.0 → IGSS.  

 
2. 
 
 

3. 
 

 
Switch to Design Mode 

Click on the drop down menu (bird) and choose Design Mode.  
 
Start the Project Wizard 
In IGSS Master select the Design and Setup tab. Then choose Project Wizard. 
The Project Wizard dialog appears. 

 
  

4. 
 

5. 
 

6. 
 
 

Select Create a new IGSS project and click Next.  
 
Choose a project name and select a project folder 
 
Select a Single User (Standalone) station type 
There are three main station types: Single User, Server and Operator. When 
running as Single User, the project is only available on the station from 
which it is run, the station is both server and operator. When running as 
Server, the project is available for all defined operators. When running as 
Operator station the project can be downloaded from the server by any of the 
defined operators. 

7. Select the station name: IGSSStation1 and add the three following components: 
• Driver: Siemens S7 TCP/IP 

• Interface: IP Network 
• Node: Node 0 

For a more detailed description of the driver setup refer to the “Set up the 
Driver Parameters” in this section. 

8. Click Finish, to end the Project Wizard. 

 
IGSS uses two key data folders: 
• one for the project data (Project root folder), for example, project file (<MyConfig.elm), project 

database (<MyConfig >.mdb), etc. 

Purpose 

To create a new 
project 

Data folders 
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• one for the data files (Report folder), for example, base class files (.bcl), log files (.log), alarm files 
(.alm), etc. 

For details about project folders and files, search for “configurations; folders and files” in the Definition 
Help file. 
 

Define the IGSS Station Type 
 
If you haven’t done this  in the project wizard, you can manually add a new station in the System 
Configuration module To open this module, open IGSS Master and select Design and Setup  System 
Configuration. 
Before you start using an IGSS station, you must specify the station type (single-user, operator or server) 
and assign a unique station name to it. 
 
Perform the following steps: 
 

Step Action 

1. Select Edit → New Station, a new station is added. 

2. 
Click the station icon,  , in the tree view. 

3. Click the Station tab.  

 
Figure 3.2 On this tab you select the Station type and assign a unique name to it. 

4. In the Station type group, select the appropriate station type. In this case, we 
select Single User a.k.a Standalone. 

5. Type IgssStation1 in the IGSS Station name box. 
 

 
  

Purpose 

To define IGSS 
station type 
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When you choose a project in IGSS Master, it automatically becomes the active project. 
 

Set Up the Station Configuration Parameters 
 
We will now go through a further setup of the station.  We will go through the following tabs: 
• Configuration 
• Data Collection 
• Alarm 
• Access Control 
• Supervise 
Review the project parameters to verify that they are set as described in this section 
 
Perform the following steps: 
 

Step Action 

1. Click the Configuration tab. 

 
 Figure 3.3 On this tab you specify the key data management settings. 

2. Modify the settings as shown above. 

 
Even though you may change these parameters, remember that: 
• the system has a default setting for each parameter so you do not have to make any changes and  
• each parameter may be changed at any time later in the configuration process - BUT you should be 

aware, that alterations will affect the entire project as well as the data collection.  
The following important global parameters can be modified on the Configuration tab: 
 

Parameter Description 

Max. number of 
objects 

Shows the number of objects allowed in your project. The figure is 
read from the license file, Options.txt. 

Scan intervals Type the four scan intervals that you want to be able to apply to the 
IGSS objects in the project. The four scan intervals will be shown on 
the Data Management Definitions tab and you will choose one of 
them for each IGSS object. 

Selecting the 
active project 

Purpose 

To set up 
configuration 
parameters 

Configuration 
parameters tab 
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Parameter Description 

Base intervals Type the four base intervals that you want to be able to apply to the 
IGSS objects in the project. The base interval determines how often 
the scanned values are reduced to a reduced value. The data 
reduction method is selected in the Data reduction group. 
The four base intervals will be shown on the Data Management 
Definitions tab and you will choose one of them for each IGSS 
object. 

Log changes  Type the four percentages with which you want to filter value 
changes. Generally, IGSS logs values only when a value has changed 
since the previous scan, but you may define that a change must be 
greater than, for example, 5 % to be registered as a change from the 
Data Management Definitions tab when you define a process 
component. 
Use this setting to prevent unnecessary logging of minor, 
insignificant changes to the object values. 

 

Set Up the Data Collection Parameters 
When you start an IGSS project, the data collection engine (DC) is started. DC handles many different tasks 
including updating of alarm, log and base class files, printing of alarm and log data. On this tab, you 
determine how you want DC to operate. 
 

Step Action 

1. Click the Data Collection tab. 

 
 Figure 3.4 On this tab you specify the data collection parameters. 

2. Modify the settings as shown above. 
 
The most important data collection parameters are: 
 

Parameter Description  

Start with 
extended logging 

Check this box if you want to log all values from the PLC driver. 
This may be useful for troubleshooting purposes. 
NOTE: The values are saved in the <MyConfig >.scn file in the 
report folder. By default, only alarm data packets are written to the 
file. 

Purpose 
 
 
To set up data 
collection 
parameters 
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Run simulated Check this box if you want to use simulated data contained in the 
<MyConfig>.sim file. See “Simulate Process Values” in this 
section. 

 

 
 
Use the default settings in the project. 

 
  

To set up alarm 
parameters 
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On this tab you define the settings for the Alarm module, for the selected station. 
The most important alarm parameters are: 
 

Parameter Description  

Full alarm count Check this box if you want to count all alarms, this includes 
acknowledged alarms in the alarm count. 

Use function keys 
to ack. alarms 

NOTE: Check this box if you want to use function keys to 
acknowledge alarms. In the alarm list you simply press the function 
key corresponding to the number of the alarm to acknowledge it. 

Lock icon position Check this box if you want to lock the icon position. This is mainly 
intended for multiuser systems. 

Lock window 
position 

Check this box if you want to lock the window position. This is 
mainly intended for multiuser systems. 

 
  

Alarm tab 
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Use the default settings in the project. 

 
 
On this tab you define the settings concerning access control. Access control is a security mechanism used 
to prevent unauthorized access to certain functions in the system. When a user is logged in, all activities 
such as sending of commands, acknowledging of alarms, etc. are registered with user name. 
The most important access control parameters are: 
 

Parameter Description  

Disable access 
control 

Check this box if you want to disable access control. 

Force user login at 
program startup 

NOTE: Check this box if you want to force the user to login at 
program startup. 

 

 
 
  

To set up access 
control 
parameters 

Access Control 
tab 



22 IGSS Getting Started  

Use the default settings in the project. If you select another language, you should be aware that this manual 
is based on the English language. 

 
 
 
On this tab you define the settings for the Supervise module and choose language.  
The most important parameters are: 
 

Parameter Description  

Allow diagram 
move 

Check this box if you want the operator to be able to move the 
diagrams in Supervise. 

Allow diagram 
resize 

NOTE: Check this box if you want the operator to be able to resize 
the diagrams in Supervise. 

Allow graph move 
and resize 

Check this box if you want the operator to be able to move and 
resize graphs in Supervise. 

Allow editing of 
graph 

Check this box if you want the operator to be able to edit graphs in 
Supervise. 

Select Language Here you select which language you want to display in IGSS. 
Available languages are English, Danish, German, Czech, Spanish, 
French, Icelandic, Norwegian, Polish, Russian and Swedish. 

 

 
 

To set up 
Supervise & 
Language 
parameters 

Supervise & 
Language tab 
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Set Up the Alarm and Log Printers 
 
Before you can start printing alarm and log data from the system, you must set up the alarm and log 
printers. Note that you do not define a graphics printer as in the older versions of IGSS. When you print 
from Definition and Supervise, you simply select the Windows printers defined on the IGSS station. 
 
Perform the following steps: 
 

1. Click the Reports tab. 

 
 Figure 3.5 On this tab you set up the alarm and log printers. 

2. In the Alarm printer group, select the printer type (Direct or Windows). 

3. Click the Printer button and select the printer you want to use for alarm 
printouts. 

4. In the Log printer group, select the printer type (Direct or Windows). 

5. Click the Printer button and select the printer you want to use for log 
printouts. 

6.    
 
 

7. 
 
 

In the Headings group, you can type the information you want to show on all 
printouts from the system. This would typically be the plant name. 
 
In Output engine, you choose the output format for the report as HTML or 
Excel.  
Mail delivery allows you to send a report per mail. You must enter an SMTP 
server and mail address from which it will be sent. 
  

 

NOTE: If you are using the Direct option, only 1 line will be printed at a time, typically on a matrix printer. 
If you are using the Windows option, you will be using the Windows printer driver which will print one page 
at a time. 
TIP: Use the Page Setup button to specify paper size, paper orientation, margins, etc. 
 
For our sample project, we will keep the default settings for the remaining tabs in System Configuration. 
 

Purpose 

 
To set up alarm 
and log printers 

The remaining 
tabs  
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Set up the Driver Parameters  
 
This is a more detailed description of defining the driver. Before we start defining the process components 
in Definition, we must set up the PLC driver(s) we want to use. 
 
For our small project, we use the Siemens S7 TCP/IP driver. We define one node (PLC) to which all the 
process components are connected.   
 
 

Step Action 

1. Make sure that you are on the station level  

 
. 
Select Edit → New driver or click and double-click the Siemens S7 TCP/IP 
driver. 

 
Figure 3.6 Double-click the driver you want to include in the driver profile. 

 

2. Make sure that you are on the driver level 
Select Edit → New Interface or click . An IP Network interface is 
automatically added in the tree view.  
NOTE:  

Purpose 

This example 

To define the 
driver 
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3. Click the + sign beside IP Network and notice that IGSS has automatically 
added the first node (PLC). Select the node icon to view the node properties. 
As you can see, node number 0 is suggested and we will keep this setting. 

 
Figure 3.7 The tree view shows all the components of the driver profile. You 
can expand or collapse the view using the + and - signs. 

 

 
If you need to communicate with PLCs that do not have a direct connection to an IGSS server or operator 
station, you can communicate with those PLCs (called subnodes in IGSS) through a manager node (gateway 
PLC). This may be the case if you have two separate networks in a plant, a LAN network and a dedicated 
PLC network. The gateway PLC would then be accessible through the LAN network and would handle all 
communication to the subnode(s) on the PLC network. 
 
For further details on subnodes, search for "subnodes" in the System Configuration Help file. 
 
In System Configuration, you can exchange different kinds of telegrams between IGSS and the PLCs 
(nodes). These telegrams include system events, time synchronization and keep alive telegrams. They are 
defined on the Advanced tab at the node level. 
For further details, search for "telegrams; using extended services" in the System Configuration Help file. 
 

Make the Background Drawings 
 
The background drawing for the project of a process diagram holds all that is static in the process. The 
dynamic process components are subsequently defined in Definition. 
NOTE: You can also use a background color for your diagrams and build the process picture from scratch.  
 
In IGSS, you have two alternatives for the diagram background: 
1: Background color 
You choose a background color and draw the static elements of the diagram using the built-in IGSS 
drawing tools found in the Drawing toolbar. This allows you to take individual graphics and resize and 
position them freely on the diagram and to use shapes like lines, polygons, rectangles, etc. 
To avoid scaling/resizing problems, it is recommended to use the built-in IGSS drawing functions. 
 
 
2: Background picture 
In order to use a background drawing in IGSS, it must be saved in one of the supported formats. To view 
the list of supported formats, open the Diagram Properties dialog box, select the Picture option, click 

Subnodes 

Special types of 
telegrams 

Purpose 

Background color 
or background 
picture? 
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Browse and open the Files of type drop-down list. The supported file formats include the well-known 
formats used on the Internet (*.jpg and *.gif). 
7T recommends using file formats generally supported by Microsoft Windows. For background pictures, it 
is recommended to use vector-based file formats to avoid resizing problems. For example, the Enhanced 
Metafiles (.emf) format is very well-suited for IGSS applications. 
 
Perform the following steps: 
 

Step Action 

1. Open the drawing program you have chosen to use 

2. Draw the background picture. Include all parts that are static in the process.  
TIP: You do not need to include static text on the picture. This can be done 
directly in Definition where the text can be freely formatted. 

 
 Figure 3.8 The background picture is made in an external drawing 

application. 

3. Save or convert the picture to one of the supported formats considering the 
above recommendations about file formats. 

 

Plan the Alarm Texts 
 
We recommend that you plan and structure alarm texts, priorities and alarm colors at an early stage in the 
configuration process to obtain consistency. Planning decisions include determining the number of alarm 
priorities to be used, associating a color with each alarm priority, planning reuse of alarm texts (the same 
alarm text can be associated with as many objects as you like). 
 
An alarm text is a general description of an error situation, for example, “Motor overheated”. Each alarm 
text consists of the following properties: 
 

Component Description 

Alarm No. Identifies the alarm text with a unique alarm number. If you are 
creating a new alarm text, the next available number is automatically 
suggested, but you can change it, if required.  

Priority Type a priority from 255 (highest priority) to 1 (lowest priority).  
TIP: Carefully plan alarm priorities and their associated colors. To 
help the operator immediately understand the alarm priority, be 
consistent and use only a limited number of alarm priorities. 

To create a 
background 
drawingpicture 

Purpose 

What is an alarm 
text? 
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Alarm and 
acknowledge 
colors 

Specify the colors for alarm and acknowledged states and enable or 
disable blinking of object symbols on process diagrams. 
TIP: To help the operator easily distinguish between an object in 
alarm and an object where the alarm is acknowledged, check 
Blinking for the alarm color and uncheck it for the acknowledge 
color.  

Alarm Text Write a brief description of the alarm situation. This is the text that 
the operator will see in the Alarm List when the alarm occurs. 

Sound Specify whether you want to play a sound when this alarm occurs. 
The sound can be either a beep or a sound file (*.wav). 

Event on alarm Specify the event(s) you want to trigger when this alarm occurs. The 
following events are available: 
• To Notifier sends the alarm number via Notifier to mobile 

phones. Use this function to ensure that alarms are handled 
during periods where the operator stations are unmanned. 
Notifier is a separate sales module. 

• To PLC sends an alarm change telegram to the selected PLC, 
provided that this telegram type is enabled in System 
Configuration. 

• To Print prints the alarm text on the alarm printer. 
• Auto Acknowledge automatically acknowledges the alarm when 

it occurs. Use this setting for intermittent alarms. 
Instructions Gives recommended operator action should this alarm situation arise. 

The operator can access the instructions from the process diagram 
and from the alarm list. 

Copy Select an existing alarm text in the drop-down list, and then click 
Copy to copy its properties to the current alarm text. The properties 
can then be freely changed. 

 

Draw the New Symbols 
 
IGSS comes with a large library of symbols (about 150). If these symbols are sufficient for your needs, you 
can skip this procedure. However, you can easily modify the existing symbols or draw new symbols. 
 
The above-mentioned library of symbols is contained in the symbol file, Symbols.v20. The file consists of a 
number of subtables, each containing symbols for a specific type of component, for example, valves. The 
names of the subtables of Symbols.v20 are the ones you see in lower part of the Objects menu and on the 
Symbol Definition tab when you define process components. You can change the names of the subtables in 
Symbol Editor. 
  

Purpose 

Symbol tables 
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Perform the following steps: 
 

Step Action 

1. In Definition go to Edit → Symbols… 

2. Open the Symbols.v20 file located in the [Installation path]\Gssdemo\Eng 
folder. In Windows Vista the folder Gssdemo\ is located in 
C:\ProgramData\[IGSS installation path] 

 
3. In the List of Symbol Tables, click the subtable to which you want to append 

a new symbol.  

4. Use the scroll bar to find an empty symbol position marked No Name and 
select it.  

5. REFERENCE: Draw the new symbol. 

6. 
Click  to save the Symbols.v20 file. 
RESULT: You can now select the new symbol, when you define a new 
process component in Definition. 

 

 

Checklist Review - Setting Up and Preconfiguring 
 
The Setting Up and Preconfiguring phase is now completed. To sum up, we have now done the following: 

Procedure Mark when completed 

Created the new project √ 

Define IGSS station type √ 

Set up the station parameters √ 

Set up the driver parameters √ 

Made background drawings √ 

Planed alarm texts √ 

Draw new symbols √ 

To draw new 
symbols 

Review 
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Section C: Mandatory Design Procedures 

Overview 
 
This section contains the following information: 
• A short introduction to the Definition module 
• Step-by-step procedures for creating the sample project 
 
This section contains the following topics: 
Checklist Review - Mandatory Design Procedures  ............................................................ 30 
The Definition Program ....................................................................................................... 30 
Define Measurement Units .................................................................................................. 31 
Define Areas and Diagrams ................................................................................................. 32 
Define Alarm Texts ............................................................................................................. 34 
Define Digital Templates ..................................................................................................... 37 
Define Digital Objects ......................................................................................................... 42 
Define Analog Objects ........................................................................................................ 44 
Define Table Objects ........................................................................................................... 50 
Define Counter Objects ....................................................................................................... 54 
Define String Objects .......................................................................................................... 57 
Define Graph Windows ....................................................................................................... 60 
Install the Project ................................................................................................................. 61 
Define Operator Reports ...................................................................................................... 64 
 

About this section 

Contents 
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Checklist Review - Mandatory Design Procedures 
 
Let us take a look at the checklist again and see what we need to do to complete the project: 

Procedure Mark when completed 

Define areas and diagrams (Overview)  

Define scaling objects (Fahren.toCel) and 
templates (VALVE) 

 

Define digital objects (V1 and V2)  

Define analog objects (F0147 and L0147)  

Define table objects (T0147)  

Define counter objects (C0147)  

Define string objects (Message)  

Define alarm texts  

Define graph windows (G0147)  

Simulate process values  

Install the project and troubleshoot  

Define operator reports  

The Definition Module 
 
Most of the remaining procedures in this section are performed in Definition. This topic tells you how to 
access Definition and gives a brief introduction to the menus. 
 
Click Start → Programs → IGSS 9.0 → IGSS Master →Switch to Design Mode →Definition  
The table below summarizes the pull-down menus in Definition: 
 

This menu … allows you to … 

File check and install projects, import/export Groups revert to the previous 
version and print diagrams or screen pictures. 
NOTE: It is recommended that you save your work regularly using 
the Save command (the keyboard shortcut is CTRL + S). 

Edit cut, copy, paste and delete objects or just their references on a 
diagram, select and find objects, edit alarm texts, manage Groups, 
create measurement units and report formats. 
TIP: You can also view the properties of an IGSS object by right-
clicking the object and selecting Properties in the popup menu.  

View show or hide the toolbars and the status bar, change the date/time 
display, and show all states of digital objects. 

Format format text, set colors, set up multiple screens, set grid size and enable 
snap to grid, set initial display for each area, align objects and stack 
objects on the diagram. 

Area create and delete areas, edit area properties and select any of the 
existing areas in the current projevt provided that the Name to Menu 
option is selected for each area. 

Diagram create and delete diagrams, edit diagram properties and select any of 
the existing diagrams within the current area provided that the Name to 
Menu option is selected for each diagram. 

What we need to 
do 

Introduction 

To start  

Menus in 
Definition 
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This menu … allows you to … 

Graph create and delete graphs and select any of the existing graphs within 
the current area provided that the Name to Menu option is selected for 
each graph. 

Template edit, create and delete templates. 

Objects define any type of object. The first section of the menu allows you to 
create, edit and delete objects. The second section allows you to 
choose between the standard display types and descriptors. The third 
section allows you to choose between the symbol tables in the current 
symbol file.  
NOTE:  This menu is only available when a diagram is open. 

User Programs add links to external programs to be shown either in the Definition or 
the Supervise module. 

Tools configure the menus and toolbars of Definition and Supervise, delete 
all objects or delete all objects except templates and create VBA 
macros or open the Visual Basic Editor. 

Views create different views for different scenarios. It allows to show/hide 
selected object values/states that might be useful to a view exclusively. 

Window close the current window and select any of the currently open diagram 
or graph windows. 

Help open the Definition Help file and view the version number. 

 
For details about the individual menu items, search for “menus” in the Definition Help file. 
 
Apart from the pull-down menus, a number of right-click menus (or context menus) are available. 
For further details, search for “right-click menus” in the Definition Help file. 
 
 
To provide easy access to the most frequently used commands, a number of toolbars are available. Some of 
them are predefined; others can be customized by you.  
For further details, search for “toolbars” in the Definition Help file. 

Define Measurement Units 
 
Some of the process components have a measurement unit. We will now define all the units we need for the 
project and these units are then selected as part of the object definition procedure. 
 
To ensure consistency in the use of measurement units, IGSS features a number of unit-related functions. 
You start by creating a units set into which the individual base units are put. 
By default, a set of units called SI is included. You can define your own sets of units, if required. If you 
convert a project from an older version, the units are imported into the SI units set. 
For further details about units sets and unit conversion, search for "units" in the Definition Help file. 
  

Right-click menus 

Toolbars 

Purpose 

Units in IGSS 
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For the sample project we need the following measurement units: 
 

Object name Unit 

F0147 l/h 

L0147 l 

C0147 l/h 

T0147 °C 
 

You can write the ° sign by typing ALT+0176. 
 
We need three different measurement units which are defined as follows: 
 

Step Action 

1. Select Edit → Measurement Units. The Base Units dialog box appears. 

2. Click New to add a new base unit. 
• In the Unit text field, type l for litre. 
• Click OK to save and return to the Base Units dialog box. 

 
 Figure 3.9 In this dialog box you define new base units. If you have several 

units sets, you select the relevant one in the drop-down list. 

3. Repeat step 2 for the l/h and °C base units. 

 
 Figure 3.10 The three base units are now created and can be chosen when 

we later create the process components. 

TIP: You can write the ° sign by typing ALT+0176. 

4. Click Close. 

Define Areas and Diagrams 
 
Before we start defining the process components, we need an area and the process diagram on which we 
want to show the process.  
For details about areas and diagrams, refer to “The Area Object Type” and “The Diagram Object Type” in 
Chapter 2. 
 
For our small process we only need one area. We will use the built-in area called Global.  
  

Units in the 
project 

To define 
measurement 
units 

Purpose 

To define the area 
(Global) 
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We will define the diagram for our process which we will call Overview. Perform the following steps: 
 

Step Action 

1. Select Diagram → Create. The Diagram Properties dialog box appears. 

 
 Figure 3.11  In this dialog box you define the properties of the Overview 

diagram. 

2. In the Name field, type Overview and leave the Description field blank. 

3. Check the Name to Menu option to allow operators to open it from the 
Diagram menu during supervision. 

4. Leave the Keep Window option unchecked. 
NOTE:  During supervision four diagrams may be open simultaneously. 
When diagram number five is opened, the system automatically closes the 
first one. However, if you check the Keep Window option, the diagram is 
never closed automatically. In this case we only have one diagram, so there is 
no need to use the option. 

5. Define which window elements you want to show on the diagram, for 
example, Status Bar (the information line at the bottom of the diagram). 

To define the 
diagram 
(Overview) 
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Step Action 

6. In the Background group, select Picture and click Browse to find the picture 
which is located in the [Install Path]\Samples folder. The Open a 
Background Picture dialog box appears. 

 
 Figure 3.12  In this dialog box you choose the background picture for the 

diagram. 

7. Double-click the image you want to have as background. 

8. Click OK. 
RESULT: The new Overview diagram appears. Here is an example of a 
diagram with a background: 

 
 Figure 3.13 The Overview diagram is ready. 

 
 

 

Define Alarm Texts 
 
Before we start defining the individual components, we will create the alarm texts to be used in the project. 
We recommend that you plan the alarm texts at an early stage to ensure consistent use of alarm priorities 
and colors. Careful planning will also maximize the reuse of alarm texts. 
 
One of the things that happen when a component enters a state of alarm during supervision is that a text 
describing the alarm situation is shown in the Alarm List. The alarm texts in the Alarm List are displayed in 

Introduction 

How the operator 
views alarms 
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different colors depending on how critical the alarm situation is. In the figure below the column Alarm Text 
shows the user-defined alarm texts, below the alarm list the event list is placed. 

 
 Figure 3.14 The Alarm List provides the operator with an overview of all active alarms and gives access to 

historical alarms in the Alarm Log. The event list shows all the defined events. 

 
 
 
For our project we need the following alarm texts: 
 

For these components … we need alarm texts if … 

Valves they are defective. 

Flow the flow is too high, much too high, too low or much too 
low, that is, we need four alarm texts. 

Level the level is too high or too low. 
 

 
We need to create the following alarm texts: 
TIP: We recommend that you associate each alarm priority with one color. A consistent use of colors will 
ensure that the operator immediately recognizes the importance of an alarm. 
 

Alarm 
no. 

Priority Alarm color Alarm text Instructions 

101 5
  

Light red Valve defective  

102 6 Red Flow exceeds high 
alarm 

 

103 5
  

Light red Flow exceeds high 
limit 

 

104 5
  

Light red Flow below low limit  

105 6
  

Red Flow below low alarm  

106 5 Light red Level too high The level in the basin is 
too high. Open safety 
valve ... 

107 5 Light red Level too low The level in the basin is 
too low. Pour faster... 

  

NOTE: Fill in the remaining properties as you like. It is recommended to enable Blinking for alarm color 
and disable it for acknowledgement color. In that case, the component in alarm will blink on the process 
diagram and will stop blinking when the operator acknowledges the alarm. 
 
In IGSS you can create and edit alarm texts as follows: 
• from the Alarm Details dialog box accessed from the Edit → Alarm Texts menu   

Alarm texts for 
this project 

Alarm text 
properties  

Two ways of 
defining alarm 
texts 
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• from the Edit Alarm Description dialog box accessed from the Edit Mapping tab of the object properties 
dialog box 

 
The following procedure describes how you define all the above alarm texts from the Alarm Details dialog 
box. The alternative is to create the alarm texts as part of the object definition procedure. 

Step Action 

1. Select Edit → Alarm Texts. The Alarm Details dialog box appears. 

 
Figure 3.15 From the Alarm Details dialog box you can create, edit and delete alarm 

texts for the current project. 

2. Click New to add the first alarm text. The Edit Alarm Description dialog box 
appears. 

 
 Figure 3.16 In this dialog box you create new alarm texts or edit existing 

ones. 

3. Specify the alarm properties from the table above and fill in the remaining 
properties, as you like. 

 
Figure 3.17  The first alarm text is ready for use.. 

4. Click OK to save the alarm text and return to the Alarm Details dialog box. 

To define alarm 
texts 
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5. Repeat steps 2 to 4 for the remaining alarm texts. 
RESULT: The alarm texts are now ready for use. We will merely have to 
associate them with the relevant alarm atoms when we later define the 
process components. 

6. Click Close to close the Alarm Details dialog box. 

 
For further details, search for “alarm texts” in the Definition Help file. 
 

Define Digital Templates 
 
In the project we have two valves. Instead of defining them one by one we will define a valve template to 
ensure that both valves share the same properties. 
 
Perform the following steps: 

Step Action 

1. Select Template → Create. The Create Template dialog box appears. 
Select Digital and type VALVE in the Name field and 2-state valve in 
the Description field. 

 
 Figure 3.18  In this dialog box you select the template type and type a unique 

template name and an optional description. 

2. Click OK. The digital template properties dialog box appears. 
On the Bit Map I/O tab, define a state bit in the To PC field and a command bit 
in the From PC field. See the LEGEND for an explanation of the symbols 
used. 

 
 Figure 3.19  On the Bit Map I/O tab you define the individual bits sent to and 

from IGSS. 

Purpose 

To define the 
digital template 
(VALVE) 
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Step Action 

3. Click the Alarm In/Ack bit tab and define an alarm indication bit To PC (bit 0) 
and alarm acknowledgement bits (bit 1 to PC and bit 0 from PC). 

 
 Figure 3.20 On this tab you define the alarm indication and acknowledgement 

bits. 

4. Click on the States and Commands tab. Do the following: 
• Select the default states < - 0 and type closed in the box. 
• Repeat for state < - 1 but type open. 
• Select the default command 0 - > and type close in the box and click Add 

command. 
• Repeat for command 1 - > but type open. 

 
 Figure 3.21  On the States and Commands tab you define the names of the 

individual states and commands. 
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Step Action 

5. Click the Command/State Config tab and do the following: 
• In the States list, select Closed 
• In the Commands list, clear the close check box. 
• In the Default Command drop-down list, select open. 
Repeat for the open state, but choose close as the default command. 

 
 Figure 3.22  On this tab you specify the valid and default commands for each 

state. 

6. Click the Data Management Definitions tab and set the Scan interval, Base 
interval and Data reduction to the settings shown in Figure 3.23. 

 
 Figure 3.23   On the Data Management Definitions tab you define the data 

collection properties. 
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Step Action 

7. Click the Edit Mapping tab. 
NOTE: The more information you can type into a template, the less work 
you will have when using the template to define objects. So we can type all 
address information which will be common to the valves. 

 
 Figure 3.24  On the Edit Mapping tab you define the parts of the PLC 

address which are common to the objects you will base on this template. 

8. Type the following information: 
• Select Command or State in the Atom box. 
• In the I/O mode field, select out for command and in for state. 
• Select Alarm-In and in the Alarm Details field, select alarm number 101 as 

described in “Define Alarm Texts” in Chapter 3. 
• In the Driver field, select the appropriate driver, 7TS7TCP (IgssStation1).  
• In the Node field, type 0 (the node number we defined in System 

Configuration). 
• In the Data Block Number field, type 22 for command and 23 for state. 
NOTE: To make the communication as efficient as possible, we will use one 
block for commands and another one for states. That way the driver will not 
scan any unnecessary data (i.e. commands) that will merely be discarded 
when collecting changes of state. 
• Leave the Offset field unchanged.  
• Leave the Bit Offset field open, as each object will have its own specific 

address. 
• In the External Type drop-down list, select the FP16S data type. 
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Step Action 

9. Click the Symbol Definition tab. Do the following: 
• Check the Copy symbols to template box to save the color and symbol 

selections that you are about to make as a part of the template. 
• In the Digital state for symbol field, select Closed. 
• In the Symbol color drop-down list, select a yellow color to represent the 

state. 
• In the Choose symbol group, select the symbol that you want to represent 

the state. 

  
 Figure 3.25 On the Symbol Definition tab, you select the colors and the 

symbols for the various states. 

10. Repeat step 9 for the Open state, but select a green color instead. 

11. Click OK, and the digital template is complete. 
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 Define Digital Objects 
At this point we have a diagram without any objects, a scaling object and a digital template - in other words 
we have all the basic building blocks for our project. 
We will begin by defining the two valves, V1 and V2, which use the digital template, VALVE. 
 
TIP: The only properties we need to define for the two valves are their specific PLC addresses and their 
symbols.  
Perform the following steps: 
 

Step Action 

1. Select Objects → Valves. The Object Browser dialog box appears. 
 

2. Click the + sign beside Global, then Digital and select VALVE in the Tree view 
and type V1 in the Name field. Click Create. 

 
 Figure 3.26  In this dialog box, you select the appropriate template and type 

the unique name of the new object. 

Purpose 

To define the two 
valves (V1 and V2) 



 How to Create a Project 43  

Step Action 

3. On the Edit Mapping tab, type the precise PLC addresses. We will use the 
same word offset for state and command - this will help us create consistency 
in the PLC programming. 

 
 Figure 3.27 On the Edit Mapping tab you type the precise PLC address and 

the alarm numbers. 

4. Click on the Symbol Definition tab. Do the following: 
• Click the Copy Symbols from Template button to use the color and 

symbol selections you defined as part of the template. 
TIP: If you want to turn the symbol by, for example, 90° to represent the 
state open, simply select that percentage in the Symbol Angle drop-down list.   

 
 Figure 3.28 On the Symbol Definition tab, you select colors and symbols or 

you use the selections from the template. 

5. Click OK. The two state symbols appear on the diagram. By default, they are 
placed on top of each other, but you may move them individually, if required 
(select View → Show All States). 
Position the symbol, then the name and the state. 
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Step Action 

6. Repeat steps 1 - 4 for V2, but use a Offset of 1 for both state and command. 
NOTE: As both V1 and V2 use only one state bit, we could have used 0.1 as 
the bit offset for state. However, in our example it is not necessary to pack 
the states (it is only a very small project). Also, it is pleasantly symmetrical 
to use the same bit offset for state and command.  
Note that command bits cannot be packed. The system always writes (at 
least) one word (16 bits) at a time. 

7. Click on the Symbol Definition tab and click Copy Symbols from Template to 
select the same colors and symbols as for V1. 

8. Position the symbol, name and state for V2. 

 
 Figure 3.29  The Overview diagram with the two valves in position. 

 

Define Analog Objects 
 
In our project we need two analog objects: 
• the flow meter measuring the flow into the tank, F0147 
• the water level in the tank, L0147 
 
Perform the following steps: 
 

Step Action 

1. Select Objects → Analog Elements. The Object Browser appears.  

Purpose 

To define the flow 
meter (F0147) 
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Step Action 

2. Click the + sign beside the Global and Analogue in the Name field, type 
F0147 and in the Description field, type Flow into tank T0147. 

 
 Figure 3.30 In the Definition of Object dialog box you type the unique name 

of the object and an optional description. 

3. Click Create. The analog object properties dialog box appears.  Do the 
following: 
• Adjust all the values as shown in Figure 3.31 using the keyboard or by 

moving the appropriate horizontal line in the bar to the desired value. The 
flow meter measures in the range 0 - 100 liters an hour (l/h). 

• In the Units box, select the measuring unit l/h. 
• Check the four limit and alarm boxes, High Alarm, High Limit, Low Limit 

and Low Alarm. 
NOTE: The Actual Value is, of course, updated as soon as the data collection 
starts. 

 
 Figure 3.31 On the Analog tab you specify the measuring range, the 

measuring unit and the alarm limits. 
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Step Action 

4. Click the Data Management Definitions tab and make the selections shown in 
Figure 3.32. 

 
 Figure 3.32 On the Data Management Definitions tab you define the data 

collection properties. 

5. Click the Edit Mapping tab and do the following: 
• In the Configure atom box, select Actual Value. 
• In the Data Block Number field, type 20. We choose a different data 

block for our analog measurements than for the digital ones. 
• In the Atom box, select Set Point, and set the data block number to 18. 
NOTE: The other five values are local to the PC and thus have no PLC 
address. 
• In the Atom box, select High Alarm and select the associated alarm text 

(number 102) as described in “Define Alarm Texts” in Chapter 3. 
• Repeat for High Limit (alarm no. 103), Low Limit (alarm no. 104) and Low 

Alarm (alarm no. 105). 

 
 Figure 3.33 On the Edit Mapping tab you type the specific PLC address and 

attach the appropriate alarm texts. 

6. Click the Symbol Definition tab and select a color and a symbol. 
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Step Action 

7. Click OK. The symbol appears on the diagram. Position the symbol, then the 
name and the value. See Figure 3.39. 

 

 
Perform the following steps: 
 

Step Action 

1. Select Objects → Bar Display. The Object Browser dialog box appears. 

2. Click the + sign beside Global and select Analog and type L0147 in the 
Name field, then type  Water level in tank T0147 in the 
Description field. 

 
 Figure 3.34 In the Object Browser dialog box you type the unique name of 

the object and an optional description. 

To define a bar 
display of the 
water level 
(L0147) 
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Step Action 

3. Click Create. The bar display object properties dialog box appears. Do the 
following: 
• Adjust the maximum value to 1000. 
• Remove all values except High Alarm, Actual Value and Low Alarm by 

moving the corresponding horizontal line above the top or below the 
bottom of the bar. Use the color-coding to determine which line to move. 
A quicker alternative is to clear the check boxes for the atoms you do not 
want to use on the Edit Mapping tab. 

• In the Units drop-down list, select l for liters. 

 
 Figure 3.35 On the Analog tab you specify the measuring range, the 

measuring unit and the alarm limits. 

4. Click the Data Management Definitions tab and make the selections shown in 
Figure 3.36. 

 
 Figure 3.36  On the Data Management Definitions tab you define the data 

collection properties. 
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Step Action 

5. Click the Edit Mapping tab. Do the following: 
• In the Atom box, select Actual Value and type the PLC address shown in 

Figure 3.37. 
• Select High Alarm and associate the relevant alarm text (alarm no. 106), 

then select Low Alarm and associate alarm no. 107. 

 
 Figure 3.37  On the Edit Mapping tab you type the specific PLC address 

and the appropriate alarm numbers. 

6. Click the Attributes of Bar tab. When you make new selections, the bar 
preview to the left changes accordingly. Make the selections as shown in 
Figure 3.38. 

 
 Figure 3.38 On the Attributes of Bar tab you define the layout of the bar. 
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Step Action 

7. Click OK. A small rectangle representing the bar display appears. Position the 
bar display inside the water tank and resize it so that it fits within the tank as 
shown in Figure 3.39, then position the name and the value. 

 
Figure 3.39 The Overview diagram with the bar display in the right position. 

  

  

 

Define Table Objects 
 
In our project we need to show the four temperature gauges, which measure temperatures at different levels 
in the tank. We integrate the four temperature gauges in one table object, T0147. 
 
 
Perform the following steps: 

Purpose 

To define the 
table object 
(T0147) 
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Step Action 

1. Select Objects → Rectangular Field. The Object Browser appears. 
Select Table and type the name and description as shown in Figure 3.40. 

 
 Figure 3.40 In the Object Browser you type the unique name of the object 

and an optional description. 

2. • Click Create. The table object properties dialog box appears.  
• In the Type field, select Fixed Table. 
• Type in the names and values shown in Figure 3.41. 
• In the Units drop-down list, select °C. 

• In the Minimum value field, type 0 and in the Maximum value field, type 
100. 

 
 Figure 3.41 On the Table tab you type the names of the individual 

temperature gauges and their initial values. 
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Step Action 

3. Click the Data Management Definitions tab and make the selections shown in 
Figure 3.42. 
As you can see, the selections differ from the ones for the analog objects as 
follows: 
• Logging is set to None which means that historical graphs of the object 

values cannot be shown. However, trend graphs can always be displayed, 
as they do not depend on logged data. 

• Base interval is set to None which means that there is no data reduction 
method and thus no values for the operational reports. 

• In the Scale As field, we have selected the scaling object, Fahren.toCel 
which we defined in the Define Scaling Objects section. The scaling 
object converts values between 32 and 212 to values between 0 and 100. 

• In the Base interval group set the base interval to 10. Put at checkmark in 
Minimum and Maximum in the Data reduction group. Select Reduced 
value in the Transfer to history group 

 
 Figure 3.42 On the Data Management Definitions tab you define the data 

collection properties. Note that we use the Fahren.toCel object to convert the values from 
°F to °C. 
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Step Action 

4. Click the Display tab. 
• In the State/Value group, check the Units box to show the unit beside the 

table values. 

 
 Figure 3.43 On the Display tab you define that the values and units are 

shown with the table object. 

5. Click the Edit Mapping tab and type the values shown in Figure 3.44. 
As the table object uses the external type FP16S, it occupies the addresses 
18.00 to 21.00. 
NOTE: Although the table object holds four values, you need only give one 
address, namely the one for the first value in the table. It is assumed that the 
other values in the table are on addresses that follow immediately after the 
first one. 

 
 Figure 3.44 On the Edit Mapping tab you type the specific PLC address. 
Note that you only need to specify one address. IGSS assumes that the values have 

consecutive addresses. 
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Step Action 

6. • Click OK. A small rectangle representing the table object appears. 
Position the rectangle and resize it to the appropriate size, then place the 
name above it and the values inside it. 

 
 Figure 3.45 The Overview diagram with the temperature gauges in position. 

 

 

Define Counter Objects 
 
We nearly have a complete project now. Only two things are missing: 
• The counter that counts liters in the tank and 
• The text that displays the current status 
We will start by defining the counter object, C0147. 
  

Purpose 
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Perform the following steps: 

Step Action 

1. • Select Objects → Rectangular Field. The Object Browser appears. 
• Select Counter and type the name and description as shown in Figure 

3.46. 

 
 Figure 3.46 In the Object Browser you type the unique name of the object 

and an optional description. 

2. • Click Create. The counter object properties dialog box appears. 
• Select the measuring unit and the values as shown in Figure 3.47. 

 
Figure 3.47 On the Counter tab you specify the measuring unit, the preset and 

maximum values and whether you want to enable alarm supervision (Limit check box). 

To define the 
counter object 
(C0147) 
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Step Action 

3. Click the Data Management Definitions tab and type the values shown in 
Figure 3.48. As you can see, this counter object has no logging. 
In the Base interval group set the base interval to 10. Put at checkmark in 
Maximum in the Data reduction group. Select Reduced value in the Transfer 
to history group. 

 
 Figure 3.48 On the Data Management Definitions tab you define the data 

collection properties. Note that there is no logging and base interval. 

4. Click the Display tab. 
• In the State/Value group, check the Units box to show the unit on the 

process diagram. 

5. Click the Edit Mapping tab and type the values shown in Figure 3.49.  
NOTE: We use the Offset immediately after the table object, that is, 3. 

 
 Figure 3.49 On the Edit Mapping tab you type the specific PLC address. We 

use the Offset immediately after the table object, that is, 22. 



 How to Create a Project 57  

Step Action 

6. • Click OK. A small rectangle representing the counter object appears.  
• Position the rectangle and resize it to the appropriate size, then place the 

name above it and the value inside it. 

 
 Figure 3.50 The Overview diagram with the counter object, C0147, in 

position. 

Define String Objects 
 
The last object we will place on the diagram is the text describing the current state of the process. For that 
purpose we will define the string object, Message. 
 
Perform the following steps: 

Step Action 

1. • Select Objects → Rectangular Field. The Object Browser appears. 
• Select String and type Message in the Name field 
• Clear the Name check box and check Value. 

 
 Figure 3.51 In the Object Browser you type the name of the string object. 

Purpose 

To define the 
string object 
(Message) 
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Step Action 

2. Do the following: 
• Click Create. The string object properties dialog box appears. 
• In the Maximum Length field, type 70 and type the initial string shown in 

Figure 3.52. 

 
 Figure 3.52 On the String tab you type the max length of the text and 

an initial text string. 

3. Click the Data Management Definitions tab and make the selections shown in 
Figure 3.53. 

 
 Figure 3.53  On the Data Management Definitions tab you define the data 

collection properties. Note that there is a scan interval, but no logging. 
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Step Action 

4. Click the Edit Mapping tab and type the PLC address as shown in Figure 
3.54. 
NOTE: We use a new data block for the string object, 21. 

 
 Figure 3.54 On the Edit Mapping tab you type the specific PLC address. We 

use a new data group for the string object, 21. 

5. Do the following: 
• Click OK. A small rectangle representing the string object appears.  
• Position the rectangle and resize it to the appropriate size, then place the 

text string inside it. 
RESULT:  The project is now complete. To allow the operator to open the 
Overview diagram automatically, follow the procedure below. 

 
 Figure 3.55   The Overview diagram with the string object in position showing 

the current state of the process. 
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Perform the following steps: 
 

Step Action 

1. Select Format → Set Initial Display to make this diagram open automatically 
when Supervise is started. 

2. Select File → Save or press CTRL + S to save the work you have done so far. 
NOTE:  As in any other program, you should save your work regularly to 
avoid losing valuable work and wasting the time to redo it. 

 

 
 
 

Define Graph Windows 
 
There are two graph types in IGSS. One is the well-established graph which is presented in a separate graph 
window. The procedure below describes how you define this type of graph. The second type is the 
embedded graph which can be integrated in a process diagram. This graph type allows you to create XY 
plots apart from the traditional time plot which is, of course, supported by both graph types.  
For details about the embedded graph type, refer to the Definition Help file. 
 
 
The project is actually complete, but we will also like to see the flow meter, the inlet valve and the level 
gauge in a graph window to get a general impression of the state of the tank T0147. For that purpose we 
will define the graph object, G0147. 
 
Perform the following steps: 
 

Step Action 

1. Do the following: 
• Select Graph → Create. The New Graph Properties dialog box appears. 
• Enter the name and description shown in Figure 3.60. 
• Select the Name to Menu option to show the graph name in the Graph 

menu in Supervise. 
• Select the window elements to be shown on the diagram as shown in 

Figure 3.60. 

 
Figure 3.56  In the New Graph Properties dialog box you enter the name and an 

optional description and select the window elements you want to show. 

To prepare the 
diagram for the 
operator 

Introduction 

Purpose 

To define the 
graph window 
(G0147) 
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Step Action 

2. Do the following: 
• Click OK. The Define Graph Parameters dialog box appears. 
• In the Object name column, select the objects shown in Figure 3.61 from 

the drop-down lists. 
NOTE: Leave the remaining options with the default settings. For further 
details, click the  in the upper right hand corner of the dialog box, then 
click the item you want information about.  

 
Figure 3.57  In the Define Graph Parameters dialog box you define which process 

components you want to show, graph period and layout. 

3. Do the following: 
• Click OK. The graph window appears. 
• Scale the window to the desired size and position it where you want it to 

appear on the operator’s screen. 
TIP: If you want to ensure that the graph window always opens in the same 
size and position, you can lock these properties by clearing the check box 
Allow graph move and resize on the Supervise tab in the System 
Configuration module. 

 
Figure 3.58  The graph window can be scaled and positioned as you like. 

 

Install the Project 
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The project is now ready for installation. Let us install it and correct any installation errors, if required. 
 
Perform the following steps: 
 
 

Step Action 

1. TIP: Select File → Check and Install or press CTRL + T. The Installation 
Options dialog box appears.  

2. Do the following: 
• In the Installation report settings group, check all the boxes to display this 

information in the installation report. 

 
 Figure 3.59  The Installation Options dialog box allows you to control the 

contents of the installation report, <MyConfig>.prt and various other settings.  

TIP: Check the Skip This Dialog box to install without seeing this dialog box 
in future. To show the dialog box again, hold down SHIFT while you select 
Check and Install in the File menu. 

3. The installation program is automatically launched and checks the entire 
project. 
• If the installation is successful, a message prompt appears informing you 

of how many objects the installed project holds. From the message 
prompt, you can access the installation report, <MyConfig>.prt by 
clicking the Yes button. 

• If there are any errors in the project, the Troubleshooter program appears 
automatically. The program lists the errors and allows you to correct the 
errors one by one. When all errors are corrected, repeat the installation. 

4. To run the project in Supervise, select the Start button under the Home tab in 
IGSS Master (This can be done both in Runtime or Design mode).  

  

5. If the project is running, you don’t have to stop it to update the project. 
Simply use Check and Update under the Design and Setup tab and follow 
steps 2-3 above. 

 

  

Purpose 

To install the 
project 
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When a project is successfully installed, a dialog box appears allowing you to view the installation report, 
<MyConfig>.prt. The report contains detailed information about the project, for example, scan intervals, 
base intervals, communication efficiency. 

 
 Figure 3.60  The installation report contains detailed information about the project. 

Towards the end of the installation report, important information about the efficiency of the communication 
with the PLC is included as shown in Figure 3.65. 

 
 Figure 3.61  The installation report includes information about the efficiency 

of the communication with the PLC. 

For further details about the installation report, search for “installation report” in the Definition Help file. 
  

The installation 
report 
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The Troubleshooter program 
NOTE: If your installation is not successful, the Troubleshooter program automatically appears. The 

installation errors are listed. Double-clicking an error brings up a dialog box with further details. Clicking 
the Locate Error in Definition button guides you to the object which is in error. 

 
Figure 3.62  The error log file, <MyConfig>.err, clearly marks the errors found during installation allowing you to quickly 

find the erroneous objects and correct the errors. 

 
To correct installation errors 
Perform the following steps: 
 

Step Action 

1. Double-click the line representing the error you want to correct. 

2. Click the Locate Error in Definition button to go to the properties dialog box 
for the object in error. 

3. Correct the error using the information given in the Troubleshooter program, 
and click OK. 
 

4. Repeat step 1 to 3 for all the errors. 

5. Re-install the project. 
NOTE: You cannot start a project before all errors are corrected. 

 

 
For details about installing projects, search for “installing” in the Definition Help file. 
 
 

 

Define Operator Reports 
 
The final thing we need to do is to create the operational reports which the operator will be able to access 
from the Supervise module.  
 
When you define new reports, you go through the following phases: 
• create a report format 
• create the report headings 
• include the objects in the reports 
• test the reports 
• make the reports accessible in Supervise 
 
IGSS includes the following standard report types: 
• Periodical report (daily, weekly, monthly, quarterly and yearly) 
• Snapshot report (current process values) 
• Alarm statistics report 
 

To correct 
installation errors 

Purpose 

Reporting 
workflow 

Report types 
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In this example, we will create a report format to be used for periodical reports (daily, weekly, etc.). 
Perform the following steps: 
 

Step Action 

1. Select Start → Programs → IGSS 9.0 → IGSS Master→ Switch to Design 
Mode (Under the dropdown menu) → Definition (Under Design and Setup 
tab). The Definition module starts. 

2. Click Edit → Report Formats. The Report Formats dialog box appears. 

3. • Do the following: 
• Click Create in the Report Format area. The Report Format Properties 

dialog box appears. 
• Type the name DemoRep in the Format name box. 

•  
• Check Set as default to automatically suggest this report format when the 

operator requests a report. 
• Click the Periodical report option to allow the operator to base daily, 

weekly, monthly, quarterly and yearly reports on this format. 
• Click OK to return to the Report Formats dialog box. 

 
 Figure 3.63 From this dialog box you create and maintain the report formats 

on which operator reports are based. A report format can be divided into sections 
(Report Headings). 

4. Click the Create button in the Report heading area. The Report Heading 
Properties dialog box appears.  
• Type Flow and level in the heading text box as shown in Figure 3.68. 

 
 Figure 3.64  In this dialog box you specify the names of the sections 

you want in the report. 

5. Repeat step 4 for the two other headings named “Miscellaneous” and 
“Valves” 

6. Click OK to return to the Report Formats dialog box. 
TIP:  To change the sequence of report headings, drag and drop the headings 
with the mouse. By default, headings are sorted alphabetically. 

To create a report 
format 
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7. To include the objects, first click the appropriate report heading, in this case 
“Flow and level”. Then click Browse in the Chosen objects area. The Object 
Browser appears.  
• We will now include the following objects: 

This object name Goes under this report heading  

F0147 (Min/Max) Flow and level 

L0147 (Average) Flow and level 

C0147 (Max) Miscellaneous 

T0147 (Average) Miscellaneous 

V1 (Change) Valves 

V2 (Change) Valves 
 

8. • Do the following: 
• Select the first two objects in the list by holding down CTRL while you 

click each object, and drag them onto the “Flow and level” report heading 
in the Report Formats dialog box. 

• Repeat this step for the remaining objects, dragging the objects onto the 
“Miscellaneous” and “Valves” headings, respectively. 

RESULT: The report format is now ready for use. But we still need provide 
direct access to the report modules for the operator (see “To include reports 
as user programs”). 

 
 Figure 3.65  In this dialog box you include the individual objects in the report 

and specify the report heading to which the object belongs. 

9. • Click Close to return to the Report Formats dialog box. 
 

 
The operator needs direct access to this report format, so we will include links to reports in the User 
Programs menu of the Supervise module. 
NOTE: By default, the installation program adds links to the Periodical Reports and the Snapshot Reports. 
The procedure below describes how you do this manually. 
 
Perform the following steps: 

To include reports 
as user programs 
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Step Action 

1. In Definition, select User Programs → Customize for Supervise. The Access 
to User Programs from Supervise dialog box appears. 
• Click New, then type Dmyrep.mde which is the file name of the 

Periodical Reports program. Click OK.  
NOTE: During installation, the installation path of IGSS becomes part of the 
Windows PATH environment variable. This means that you do not need to 
specify the full path. 
• In the Menu Text box, type Periodical Reports. 
• Repeat for snapshot reports. This time type the file name, Actrep.mde. 
• Click OK.  
• Install the project (see the “Install the project” procedure in this section). 

 
 Figure 3.66 In this dialog box you specify the paths and names of the 

programs you want to include in the User Programs menu of Supervise. 

2. Verify the results in Supervise as follows: 
• Select IGSS Master→ Start (Under the Home tab). 
• Select User Programs → Periodical Reports. The Periodical Reports 

dialog box appears.  

 
 Figure 3.67  In this dialog box the operator selects the appropriate report type 

and report date and selects either an overview report or a detailed report. 

 
If you want to print reports at regular intervals, we recommend using the Job Scheduler module. It allows 
you to start any program at a specified time. You may want to print a daily report every morning at 7:00 
a.m. This is easily done using Job Scheduler. 
For further details about automatic printing, refer to the Job Scheduler Help file. 
For details about reports, refer to the Report Help file. 
 
 

Automatic 
printing of reports 
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Section D: Optional Design Procedures 

Overview 
 
This section describes some of the advanced features in IGSS. To allow you to get acquainted with these 
facilities, we refine the project we have just built by using: 
• The Drawing toolbar 
• Standard descriptors (drawing objects, Windows controls, etc.) 
• The Library toolbar 
 
 
Using Advanced Features in IGSS .......................................................................................68 
Use Lines for Analog Objects ..............................................................................................70 
Use Polygons for Analog Objects ........................................................................................72 
Define Events .......................................................................................................................75 
Simple Calculations .............................................................................................................78 
Refine Bar Displays .............................................................................................................79 
Use Command Buttons for Counter Objects ........................................................................82 
Use Command Fields or Combo Boxes for Digital Objects ................................................84 
Embedded alarm list ............................................................................................................87 
Embedded Diagram .............................................................................................................88 
Grid Control .........................................................................................................................91 
Using animated symbols ......................................................................................................94 
Place Your Favourite Graphics in the Library Toolbar ........................................................96 
Property Table View  ...........................................................................................................97 
 

About this section 
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 How to Create a Project 69  

Using Advanced Features in IGSS 
 
In this section we will try out some of the advanced features in IGSS. These features allow us to present 
process components in completely new ways, for example, by using standard Windows controls. 
 
In older versions of IGSS, a background picture from an external drawing program was used, but now you 
can simply use a background color and draw the process from scratch using the Drawing toolbar and other 
features known from drawing programs. 
The figure below shows the functions of the individual buttons of the Drawing toolbar. 

 

 Figure 3.68 The Drawing toolbar allows you to create drawing objects and place graphics files and ActiveX/OLE 
objects and the embedded graph type on the process diagram. 

The components you create using the Drawing toolbar can either be static or connected to an IGSS object. In 
the latter case, the appearance of, for example, a drawing object is linked to the state or value of the process 
component. 
For details about the Drawing toolbar, search for “toolbars; Drawing toolbar” in the Definition Help file. 
 
The most typical way of showing IGSS objects on a process diagram is to use the symbols from the built-in 
symbol file, Symbols.v20. However, a number of additional ways of displaying objects are also available. 
• Drawing objects (line, polygon, etc.) 
• Windows button (button, combo box, etc.) 
• Graphics files (.bmp, .wmf, .emf, .gif, etc.) 
• Multimedia files (.avi and .gif) 
• OLE objects 
• ActiveX controls 
• Embedded Graph 
• Embedded Alarm List 
• Embedded Diagram 
• Animated Symbol 
When you use a standard descriptor to represent an IGSS object, you can link its appearance to the state or 
value of the object. 
For details about standard descriptors, search for “standard descriptors” in the Definition Help file. 
 
The Library toolbar allows you to drag and drop your favorite graphics objects onto process diagrams. 
The figure below shows the functionality of the toolbar. 

Introduction 

Drawing toolbar 

Standard 
descriptors 

Library toolbar 
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 Figure 3.69  Place your favourite graphics files on the Library toolbar and drag and drop them onto process 

diagrams. 

For details about the Library toolbar, search for “Library toolbar” in the Definition Help file. 
 

Use Lines for Analog Objects 
 
Instead of using a standard symbol from the symbol file for the flow meter, F0147, you may want to use a 
line instead. The line could be placed on top of the inlet pipe to make it evident for the operator that an 
alarm on this object is directly related to the inlet pipe. 
We will apply different colors for the alarm ranges and enable line flashing when the object is in alarm. 
 
NOTE: Before we start using the advanced features, we will create a new diagram, Overview_New. Create 
the new diagram as described in the “Create Areas and Diagrams” procedure in Section C. 
 

  Step Action 

1. Select Objects → Standard Descriptors → Line. The Object Browser dialog 
box appears. 
• Select Analog and check Value. 
• In the right window list, select F0147. 
• Click Create and the line representing the object appears.  

 
 Figure 3.70  The Object browser dialog box appears when you connect a 

standard descriptor to an IGSS object. 

Purpose 

To use a line for 
the flow meter, 
F0147 
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2. Position the line as shown in Figure 3.75, then position the name and the 
value. 

 
 Figure 3.71  Position the line on top of the inlet pipe. 

3. Double-click the line to define its properties. Click the Attributes of Line tab.  
• In the Line Color group, double-click the Bind Line Color property to 

enable it. 
• Double-click each of the color bars to choose the appropriate colors for 

the individual atoms (alarm limits). 

 
 Figure 3.72  In the Line Color group, you link the color of the line to the 

actual process value. You can specify individual colors for the different alarm ranges. 
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4. Do the following: 
• In the Bindings to Object Alarms group, double-click Flash Line to enable 

line flashing when the object is in alarm. 
• Double-click each of the color bars to choose the appropriate colors. 

 
 Figure 3.73  In the Bindings to Object Alarms group, you enable line 

flashing when the object is in alarm and choose the appropriate colors. 

5. Click OK. 
 

 
 

Use Polygons for Analog Objects 
 
If you have a tank with a non-square form, you may want to use a polygon to represent the level of the tank 
contents. In this example, we will use the existing object, L0147. We will make the background of the 
polygon flash when the process value exceeds one of the alarm limits. 
This time we will use the Drawing toolbar to create the polygon and then later connect its appearance to 
L0147. 
 
Perform the following steps: 
 

Step Action 

1. If the Drawing toolbar is not visible, select View → Drawing toolbar. 

2. Click  to activate the polygon-drawing tool. 

Purpose 

To use a polygon 
for an analog 
object 
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3. Do the following: 
• Click once where you want the top left corner of the polygon and draw 

the first vertical line. 
• Click once where you want the first line to end. 
• Repeat for all lines until you have the shape shown in Figure 3.78. 
• Double-click on the border when you have completed the polygon. 

 
 Figure 3.74  The polygon representing the tank is now drawn, ready to be 

connected to the appropriate IGSS object.  

NOTE: If you place one of the corners of the polygon incorrectly you can 
click Edit → Undo. You can redo an undo command, by clicking Edit → 
Redo. 

4. Right-click the polygon and select Connect. The Object Browser appears. 
• Select Analog and check Value.   
• In the Name area, select L0147. 
• In the open by name area, check the show properties box. 

 
 Figure 3.75 The Object Browser appears when you connect a standard 

descriptor to an IGSS object. 

5. Click Open / Select. The object properties dialog box appears. 
Click OK again, as we do not want to change any properties. The object name 
and value appear. Position them as shown in Figure 3.83. 
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6. Double-click the polygon and select the Attributes of Polygon tab.  
• In the Background Color group, double-click the Bind Background Color 

property to enable it. 
• Double-click each of the color bars and choose the appropriate colors. 

 
 Figure 3.76 In the Background Color group, you enable background flashing 

and choose the appropriate colors. 

7. Do the following: 
• In the Bindings to Object Alarms group, double-click the Flashing 

Background property to enable background flashing when the object is in 
alarm. 

• Double-click the Flash Background On Color bar and choose the 
appropriate color. 

 
 Figure 3.77  In the Bindings to Object Alarms group, you enable 

background flashing when the object enters the alarm state and choose the appropriate 
colors. 
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8. Do the following: 
• In the Miscellaneous group, double-click each of the two color bars to 

choose the fill color and pattern. 
• Double-click Fill Direction and select Up.   
• Double-click Fill Criteria and select Actual Value. 
• Double-click Fill Active to enable filling of the polygon according to the 

process value. 

 
 Figure 3.78 In the Miscellaneous group, you select the fill color and pattern 

and the fill criteria, for example, Actual Value to show the process value. These 
properties determine the filling of the polygon. 

9. Click OK. The polygon should now look like this. 
 

 
 Figure 3.79 The polygon is positioned and the filling reflects the current 

process value. 

  

 

Define Events 
 

Introduction 
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The operator uses the Event List to get a quick overview of the most important system and object events. 
The events in the list are user-defined and can be configured both from the Definition module and the 
Supervise module. The Event List is presented just below the Alarm List.  
 
The following event types can be defined for display in the Event List. 
 
• OP connect/disconnect  
• Periodical  
• System start/stop  
• User defined  
• User login/logout  
• Writing stopped/started  
• Error packet 
 
In our project we need to register an event when the water level exceeds 800 l and the valve V2 is closed, so 
that the operator gets an early warning and can take the needed corrective action, before the water level 
object enters alarm state.  
 
Perform the following steps: 
 

Step Action 

1. Select Edit → Event list…. The Events dialog box appears.  

2. Click Add. The Edit Event dialog box appears. 

3. In the Name field, type: Water level (L0147) is 800 l and V2 
is closed. 

4. In the Type drop-down list, select User defined. 

5. In the Display color list, select the color to be shown in the Event List. 

6. Select the Alarm on event check box to show the event in the Alarm List.  
NOTE: When the event is also shown in the Alarm List, the alarm and 
acknowledgement colors defined for alarm number 90 will apply. Refer to 
the “Showing events in the Alarm List topic in the Alarm help file. 

7. In the Criteria section, click the Add Criteria button. 

8. Click the Object Browser button. 

9. Find the object, V2, and drag it into the first line of the criteria field. 

10. Do the following: 
• Under Atom, select State. 
• Under Relation, select =(value). 
• Under Object/value type 0 which corresponds to the digital command 

Closed. 

Purpose 

To define the 
event for V2 and 
L0147 
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Step Action 

11. Repeat steps 7-10 for the L0147 object and do the following: 
• Under Atom, select Actual Value. 
• Under Relation, select >(value). 
• Under Object/value type 800. 

Your dialog box should look like the example below. 

 
 

12. Click OK. 

 
The event list will look like the example below when the event occurs. 
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Simple Calculations 
 
In our project we need to control the flow F0147 and the valve V1 so that the flow into the tank stops, when 
the level in the tank is 850 l or above. This is done in two steps, first closing the V1 valve when the level in 
the tank is 850 l or above, this affects the set point of F0147 (since the valve is closed the flow will be 0). 
First we define the simple calculations for the V1 valve.  
 
Perform the following steps: 

Step Action 

1. Right-click the V1 object and select Properties. 

2. Click the Calculation tab. 

3. Set a check in the Command checkbox, to enter a calculation expression. 

4. Click the expression field, and type IIF(Value(‘L0147’)>850.00, 
0,1). The tab should look as shown in Figure 3.84. 

 
Figure 3.80 The calculation expression on the Calculation tab. 

NOTE: The expression closes the valve V1 when the level in the L0147 tank 
exceeds 850.00 liters. 

5. Click the Test Expression button to test that the expression is correct.  

 
Figure 3.81 The dialog box from successful expression test. 

Click OK. 

6. Click OK to exit the properties dialog box. 

 

Purpose 

To define the 
simple calculation 
for V1 
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The next step is to define the simple calculations for the set point of F0147. 
 
Perform the following steps: 

Step Action 

1. Right-click the F0147 object and select Properties. 

2. Click the Calculation tab. 

3. Put a check mark in the SetPoint box in the Atom group. 

4. Click the expression field in the Expression group, and type: 
IIF(StateValue(‘V1’)=0,SetPoint(‘F0147’)=0,1)  

 
Figure 3.82 The calculation expression on the Calculation tab. 

5. Click the Test expression button to test that the expression is correct. Figure 
3.87 shows the dialog box from testing a correct expression.  

 
Figure 3.83 The dialog box from successful expression test.  

Click OK. 

6. Click OK to exit the properties dialog box. 

 
For further details, search for "Calculation" in the Definition Help file. 

Refine Bar Displays 
 
When we defined the object representing the water level in the tank, L0147, we defined a standard bar 
display. We will now customize the display using some of the numerous layout features available. 

To define the 
simple calculation 
for F0147 

Purpose 
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Perform the following steps: 
 

Step Action 

1. Select Objects → Bar Display. The Object Browser appears. 
• Select Analog and check Value.   
• In the Open by name area, check the Show properties box. 
• In the Name area, select L0147 and click Create. The Attributes of Bar tab 

appears.   

 
 Figure 3.84 The Object Browser dialog box appears when we define a new 

bar display. In this case, we choose the existing analog object, L0147. 

To define a bar 
display 
(advanced) 
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2. Do the following: 
• In the Show Limits group, select Lines + Arrows to show the alarm limits.  
• In the Colors and Patterns group, click Limit and select a red color for the 

alarm limit line. 
• In the Align Axis group, select Left to show the value axis to the left of the 

tank. 
• In the Bar View group, select 2-D View to show the bar two-dimensionally. 
• In the Scale Attributes group, check Show Scale and Show Values.  
• Click OK. The bar display appears. 

 
 Figure 3.85  The layout properties of the bar display have been entered. Use 

the bar preview to verify your selections. 

3. Move the bar display over the tank and resize it so that it fits within the tank 
as shown in Figure 3.90, then position the name and the value. 

 
 Figure 3.86  The bar display is positioned. Notice the two alarm limit lines 

which clearly alert the operator if the water level is nearing an alarm level. 
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Use Command Buttons for Counter Objects 
 
The counter object, C0147, which counts the number of liters let into the tank per hour, was initially defined 
as a rectangular field. By using a command button instead, we allow the operator to insert, for example, the 
preset value simply by clicking the button. 
 
Perform the following steps: 
 

Step Action 

1. Select Objects → Standard Descriptors → Button Control. The Object 
Browser dialog box appears. 
• Select Counter and check Value.   
• In the Name field, type C0147. 
• Click Create. The command button appears.   

 
 Figure 3.87  The usual Object Browser dialog box appears when we correct 

a command button to represent an IGSS object. 

2. Move the command button, the name and the value to the position shown in 
Figure 3.93 and resize the button, as required. 

Purpose 

To use a 
command button 
for a counter 
object 
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3. Double-click the button and select the Attributes of Button tab.  
• In the Command On Click group, double-click the Bind Command On 

Click property and double-click the Preset property to enable the operator 
to issue this command by clicking the button. 

• In the Miscellaneous group, double-click the Text to be displayed 
property and type Preset in the ensuing dialog box and click OK.  

 
 Figure 3.88  In the Command on Click group, you bind the button to one of 

the four counter commands the operator can issue. 

4. Click OK. The counter object should now look like this. 

 
 Figure 3.89  The command button representing the counter object is 

complete. The operator can issue the Preset command just by clicking the button. 
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Use Command Fields or Combo Boxes for Digital Objects 
 
The two valves, V1 and V2, were initially defined using standard valve symbols from the symbol file. IGSS 
provides two useful alternatives, a command field or a combo box. 
 
Perform the following steps: 
 

Step Action 

1. Select Objects → Command Field. The Object Browser dialog box appears. 
• In the Tree view, click the + sign beside Global, then the + sign beside 

Digital and select the Valve template. 
• In the list of objects, select V1. 

 
 Figure 3.90 The usual Object Browser dialog box appears when we define a 

command field.    

Purpose 

To define a digital 
object as a 
command field 
(V1) 
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2. • Click Create. The Set Command Layout tab appears. 
• Check all four boxes to the right of the preview. 
• In the Align group, select Horizontal. 

 
 Figure 3.91 On the Set Command Layout tab, you define the graphical 

display of the command field. Notice that you can show both commands and current 
state. 

3. • Click OK. The command field appears. 
• Position and resize the field as shown in Figure 3.96, then position the 

name. 

 
 Figure 3.92 The command field is positioned. Notice that the operator can 

instantly view the available commands and the current state. 
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Perform the following steps: 
 

Step Action 

1. Select Objects → Standard Descriptors → Combo Control. The Definition of 
Object Browser dialog box appears. 
• In the Tree view, click the + sign beside Global, then the + sign beside 

Digital and select the Valve template. 
• In the list of objects, select V2. 

 
 Figure 3.93 The Object Browser dialog box appears when we define a 

combo box.  

2. Position and resize the combo box as shown in Figure 3.98, then position the 
name and the state. 
TIP: To allow both commands to be shown in the drop-down list, extend the 
combo box area downwards. Click on the combo box and position the cursor 
over the centre handle in the bottom. When the hand appears, resize as 
required. 

 
 Figure 3.94  The combo box representing V2 is positioned. The operator 
selects the appropriate command by opening the drop-down list and selecting the 

command. 

 
 

To define digital 
objects as combo 
boxes (V2) 
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The Embedded Alarm List 
 
We now want to make an embedded alarm list that shows all the alarms from the flow, this will be alarm 
number 102 to 105. 
A selection of the alarms from the project can be shown in an embedded alarm list. The embedded alarm list 
may for example contain alarms from the objects on a specific diagram. 
 
Perform the following steps: 
 

Step Action 

1. Select Objects → Standard Descriptors → Embedded Alarm List. An alarm 
list is placed on the diagram. 
Place the alarm list in the upper right corner of the diagram. 

2. Right-click the background of the alarm list and select Properties. 

3. The Embedded Alarm List Properties dialog box appears. 

 
4. Click the Add... button in the Filters group. The Defining Filters dialog box 

appears. 

 

Purpose 

To use embedded 
alarm list 
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5. In the Edit Condition group do the following: 
• In the Property list select Alarm no.  
• In the Condition list select is between. 
• In the Value type 102 and 105. 

6. Click Add to add the filter condition.  The dialog box should now look like 
this. 

 
7. Click OK. 

8. In the Filters group select the Flow alarms filter, and check the Default check 
box. 

9. The diagram should now look like this. 

 
 

 

Embedded Diagrams 
 
We now want to make an embedded diagram where we can watch both the Overview diagram and the 
Overview_New diagram. To do this we first create a new diagram and name it Dualview. 
An embedded diagram collects a number of logically related subprocesses into one descriptor. The 
descriptor is embedded on a standard IGSS diagram. 
For each subprocess, a subdiagram is defined and a button appears for each of these. This results in a button 
bar from which the operator can choose the subprocess to view. 
First we create a new diagram where we put the embedded diagram. 
 
 

Purpose 
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Perform the following steps: 
 

Step Action 

1. Select Objects → Standard Descriptors → Embedded Diagram. A diagram 
appears in the upper left corner. Resize the embedded diagram descriptor. 

2. Right-click the white bar in the top of the embedded diagram, and select 
Properties. 

3. The Embedded Diagram Properties dialog box appears. Set the fraction used 
for buttons to 0.1 and the Text color as wanted. 

 
4. Click the Subdiagrams tab and click the Add button in the List of 

Subdiagrams. 

5. In the Display name field type Overview. 

6. In the Background group, select Picture and click Browse to find the picture 
which is located in the [Install Path]\Samples folder. The Open a 
Background Picture dialog box appears. 

 
 Figure 3.95 In this dialog box you choose the background picture for the 

diagram. 

7. Double-click the file Waterx.wmf. 

8. Click OK. 

To make an 
embedded 
subdiagram 
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9. Repeat the procedure for the Overview_New diagram. 
The dialog box should now look like this. 

 
10. Click OK. 

11. Your diagram should now look like this. 

 
12. Go to the Overview diagram and select all the objects. Then copy them. 

13. Go to the Dualview diagram and click the Overview subdiagram. 

14. Select Edit → Paste As Reference. Click Yes when the following prompt 
appears.  

 
15. Repeat the procedure for the Overview_New diagram. 
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16. Your diagram should look like shown below. 

 
 

Grid Control (pinnable) 
 
We now want to make a diagram containing the key values of the project. 
First create a new diagram named KeyValues. 
 
Perform the following steps:  
 

Step Action 

1. Select Objects → Standard Descriptors → Grid Control. A grid appears on the 
diagram in the top left corner. 

2. Double-click the grid. The Grid Properties dialog box appears. Click the 
Environment tab and adjust the properties so that it looks like shown in the 
figure below.  

 

Purpose 

To make a grid 
control 
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3. Click on the cell(s) you want to edit and go to the Selected Cells tab. 

 
Adjust the table so it looks like the one shown in the figure below. The cells 
can be edited when you double-click them. 

 
4. Under Object name, type the texts in the Object Name column as shown 

below. Then click the State/Value cell for the V1 row, and select Object value 
under Cell type. 

 
5. Click Browse. The Object Browser dialog box appears. 

6. Find the V1 object and click Open/Select. 

7. Select State in the atom list. 
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8. Select the background check box in the Show alarm on group to display 
when the object is in alarm state. 

9. Repeat these steps 4 to 8 for the Command/High Alarm column, but select 
Command in the list instead. 

10. Repeat the procedure for the remaining steps of the objects so that the table 
looks like the example shown in the figure below. (Select Actual Value and 
High Alarm for L0147 and F0147. For C0147 select Count. Remember to 
check the Unit with value and Show alarm boxes). 

 
11. Check and install the project. 

12. Start the project from the IGSS Master module. 

13. Select Diagram → KeyValues. 

14. Click the icon at the left edge of the title bar of the KeyValues diagram. The 
system menu appears, select Pin in the menu. 

15. You can now browse through your project while keeping the KeyValues 
diagram on top. 
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Using Animated Symbols 
 
We now want to display the V2 valve using an Animated symbol.  
 
Perform the following steps: 
 

Step Action 

1. Select View → Drawing Toolbar to open the toolbar. 

2. 
Find the  symbol and click on it, then click the diagram where you want 
the symbol to be placed. 

3. A graphic for a blower appears. 

4. Double-click the graphic and the page for Animated Symbol appears. 

 
5. Use the scroll bar to scroll down to the category Valves and use the one in to 

top left corner. 

 
6. Click OK and the graphic appears on the diagram. 

7. Right-click the symbol and select Connect…. The Object Browser appears.  

Purpose 

To make an 
Animated Symbol 
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8. Click the + sign beside Global, then Digital and select VALVE in the Tree view 
and click the V2 valve in the right pane.  

 
9. Click Open/Select. The Animated symbol is now connected to the V2 valve. 

10. Go to the Animated Symbol tab.  

11. Make the following settings for the following groups: 
In alarm: 
• Set Fill Color Mode to Shaded 
• Check the Use Alarm Color check box 
• Set Blink Mode to Invisible 
Closed: 
• Set Fill Color Mode to Shaded 
• Set Fill Color to blue 
Open: 
• Set Fill Color Mode to Shaded 
• Set Fill Color to green 
Orientation: 
• Set Flip to Vertical 
• Set Rotation to 90 
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12. Position the graphic as shown below. 

 
13. Add the following line in your *.sim file: 

10 V2 1 1 

This makes the animated symbol go into alarm state. 
 

Place Your Favorite Graphics in the Library Toolbar 
 
Let us imagine that you are creating a project for a plant that has numerous identical tanks, but they are 
placed on different process diagrams. The tank is drawn in an external drawing program, but instead of 
using the copy/paste function, we will place the graphic on the Library toolbar.  
 
Perform the following steps: 
 

Step Action 

1. Draw the tank in your favorite drawing program and export it or save it in 
one of the supported graphics formats. In the example we use the tank, tank-
2.emf, from the Demo project. 

2. Select View → Library Toolbar to show the toolbar. 

3. Do the following: 
• Right-click the toolbar and select Add New Tool in the popup menu.  
• Select the picture and click graphic you created in step 1 and click Open, 

the path is [IGSS installation path]\Gssdemo\ENG. In Windows Vista 
the folder Gssdemo\ is located in the C:\ProgramData\[IGSS installation 
path] folder. The graphic appears on the toolbar. 

 
Figure 3.96  In this dialog box you select the graphic you want to place on the Library 

toolbar. Check the Show Preview box to view the graphic. 

Purpose 

To use the Library 
toolbar 
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4. Do the following: 
• Right-click the graphic in the toolbar and select Edit Tool Name in the 

popup menu.  
• Type Tank 2 in the ensuing dialog box and click OK.  

 
Figure 3.97  In this dialog box you type the name you want to show along with the 

graphic thumbnail on the Library toolbar. 

5. Click the graphic in the toolbar and drag it onto the process diagram.  

 
Figure 3.98  The tank has been dragged from the Library toolbar onto the process 

diagram. The tank can be reused any number of times you like. 
 

 

Property Table View 
 
Let us say that you have created a project and you find out that you need to change the nodes for all of the 
objects in one specific diagram. You can then go to the diagram open the Property Table View, and make 
the changes for all of the objects much faster than if you were to edit the properties for every single object.  
 
Perform the following steps: 
 

Step Action 

1. Go to the Overview_New diagram. Select Diagram → Property Table View. 
The Property Table View appears. 

2. Click the Atom level. The properties for the atoms are displayed in the right 
pane. 

 

Purpose 

To use the 
Property Table 
View 
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3. Click the Node column. Enter 0 for each object. The table should now look 
like the example below. 

 

Chapter 3:  IGSS Types and Templates 
 
 
This chapter contains the following information: 
• Definitions of the key IGSS object types 
• Examples of their typical use 
• Detailed descriptions of each IGSS object type 
• A description of IGSS templates 
 
This chapter contains the following sections: 
 
Section A: IGSS Types ........................................................................................................99 
Section B: IGSS Templates................................................................................................130 
 

About this 
chapter 

Contents 
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Section A: IGSS Types 

Overview 
 
This section contains the following information: 
• Descriptions of each IGSS object type 
• Descriptions of the most important object properties 
• Descriptions of the dialogs used when defining new objects 
• A visual guide highlighting the most important properties 
 
What Is an IGSS Type? ..................................................................................................... 100 
The Area Object Type ....................................................................................................... 104 
The Diagram Object Type ................................................................................................. 105 
The Graph Object Type ..................................................................................................... 109 
The Analog Object Type ................................................................................................... 111 
The Table Object Type ...................................................................................................... 116 
The Counter Object Type .................................................................................................. 119 
The Digital Object Type .................................................................................................... 121 
The String Object Type ..................................................................................................... 122 
The Scaling Object Type ................................................................................................... 124 
The Group Object Type ..................................................................................................... 125 
Visual Guide to Object Types............................................................................................ 127 
 

About this section 

Contents 
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What Is an IGSS Type? 
 
An IGSS type is a predefined system object that ensures that you provide all the necessary information 
about each process component you define.  
It reflects real life in the sense that different kinds of information are required for different types of objects. 
For example, for a motor you need to be able to start and stop it and know its maximum capacity. For a 
temperature gauge, you need to tell IGSS the temperature range you want to accept and the unit of 
measurement. 
 
Each time you define a process component (an IGSS object), it must have the properties of one of the IGSS 
types. When the relevant type is selected, you are automatically guided through a definition sequence 
ensuring that you provide all the necessary information. 
 
The following types are used in IGSS: 
• Area 
• Diagram 
• Graph 
• Analog 
• Table 
• Counter 
• Digital 
• String 
• Scaling 
Area, diagram and graph are non-process objects, that is, they do not represent a physical process 
component, but they are containers of other objects. The remaining object types represent process 
components, except scaling which is an internal object. 
For a detailed description of each type, refer to the descriptions in this section. 
 
As you can see, an IGSS type is a generic system object. When building projects you will often see that 
many real life components are similar or share a number of properties: one type of valve may be closed, half 
open and open, one type of level gauge may measure levels between zero and 1000 m3. To automate the 
definition of such components, IGSS includes a facility to define your own templates when components are 
identical or share several properties. A template holds all the information which is common to this set of 
objects. Templates make it very fast to configure and to make several similar projects. For further 
information about templates, refer to Section B of this chapter. 
 
When you define a process component, use the object wizard and you go through the following steps: 
NOTE: The Object Wizard is only used in this general definition of a process component, otherwise the 
traditional way of defining a process component is used to give a better understanding of the settings you 
make.  
NOTE: This procedure applies to the standard object types: analog, digital, counter, table and string. 
Therefore except area, diagram, and graph, and special display types are not included. For specific 
information on a particular type, refer to the descriptions in this section. Most of the steps tabs described in 
the procedure are common to all object types. However, if you are using special display types, for example, 
bar display, the Symbol Definition tab will be replaced by a special tab for that display type.   

Definition 

Use 

IGSS types 

Type versus 
template 

Defining a 
process 
component 
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Step Action 

1 Do the following: 
• Select Objects → Create → By Using Object Wizard… The Object 

WizardBrowser dialog appears.  
• Click Next. 
 

 
Figure 2.1 The welcome page of the object wizard 

2 In the next dialog you select the type of object you want to create, and give it a 
specific name.  
Click Next. 

 
Figure 2.2 In this dialog you select the type of object you want to use and give it specific 

name. 
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3 In this dialog you specify the PLC address(es) where the data for this component 
is available or to which data must be written. It can be located on the Edit 
Mapping tab in the object property dialog.  
Click Next. 

 
Figure 2.3 In this dialog you specify the PLC address(es). 

4 In this dialog you specify the value range, the actual value, the set point and the 
alarm texts. In the object property dialog the entered values and alarm texts can be 
located on the Edit Mapping tab and the type-specific tab (in this example the 
Analog tab.). 
Click Next. 

 
Figure 2.4 In this dialog you set the values and the alarm texts. 
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5 In this dialog you specify the scan interval. It can be located on the Data 
Management Definition tab in the object property dialog.  
Click Next. 

 
Figure 2.5 In this dialog you specify the scan interval. 

6 In this dialog you specify the base interval. It can be located on the Data 
Management Definition tab in the object property dialog.  
Click Next. 

 
Figure 2.6 In this dialog you specify the base interval. 
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7 In this dialog you specify the log settings. It can be located on the Data 
Management Definition tab in the object property dialog.  
Click Next. 

 
Figure 2.7 In this dialog you specify the log settings. 

8 In this dialog you specify the symbol you want to use for the process component 
and what to display with the symbol. It can be located on the Symbol Definition 
tab and the Display in the object property dialog. 
Click Finish. 

 
Figure 2.8 In this dialog you select the symbol and specify what to display. 

9 Position the object symbol and caption on the diagram. 
 

 

The Area Object Type 
 
An area is a collection of diagrams, graphs and objects that belong together. 
 
Typically an area is used to depict a production line or a separate section of the process. If the process 
cannot be seen as divided into sections, only one area is used. 
 
IGSS includes a default area called Global. Everything that is defined in this area is global to the entire 

Definition 

Use 

Global area 



 IGSS Types and Templates 105  

project and may be used in any other area. Therefore, it is always a good idea to define templates and 
scaling objects in this area. For a description of how you define these objects, refer to “Define Scaling 
Objects and Templates” in Chapter 3. 
 
When building your own projects, you need to define your own areas. There are a few things to remember 
when defining your own areas: 
• Give the area a unique and descriptive name so that it is easily recognised in the Area menu. 
• All objects defined in a user-defined area are not available in other areas. If you know that a particular 

object will only be used in one particular area, define it there to limit the number of global objects. 
 
The Area menu contains all available areas provided that the Name to Menu option is selected for each area 
(see below). These areas are selected by the operator in the Area menu of Supervise. 
 
 

Step Action 

1 Select Area → Create.  The New Area Properties dialog appears. 

 
 Figure 2.9  In the New Area Properties dialog give the area a unique name 

and select the Name to Menu option to show the name in the Area menu. 

2 Type a unique name and select the Name to Menu option to show the area 
name in the Area menu. 

3 If required, enter a default node number and select a default PLC driver. 
NOTE: The default node and driver are automatically suggested for all 
objects you create in this area. 

4 Optionally, attach a Protect object to protect the area against unauthorized 
access. 
NOTE: For further information about user administration, refer to the Help 
function of User Administration. 

 

For further details about areas, search for “areas” in the Definition Help file.  
 

The Diagram Object Type 
 
A diagram provides a graphical view of a section of the monitored process. A diagram typically consists of 
a static background picture, a number of static process objects and connectors and, most importantly, the 
dynamic process components represented as symbols. A process diagram is often called a mimic diagram. 
 
A diagram defined in Definition is exactly the same diagram that the operator sees during supervision. 
Depending on the complexity of the process, an area may contain a number of diagrams each representing a 
section of the process. A diagram gives the operator a quick overview of the monitored process and clear 
visual indication if there are any alarms. 

User-defined 
areas 

Area menu 

Defining an area 
object 

Definition 

Use 
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In older versions of IGSS, the background picture of a diagram was made in an external drawing application 
in either bitmap (*.bmp) or Windows metafile (*.wmf) format. This option is still available, but many new 
graphics formats are supported, for example, Enhanced Metafile (*.emf) and Graphics Interchange Format 
(*.gif). 
You can also use a background color and build the diagram from scratch. You may still need an external 
drawing application to create static components, such as tanks, containers, etc. but these components can 
then be freely positioned and resized on the diagram. You can easily draw the connectors between 
components using the Drawing toolbar. 
 
The Diagram menu shows all available diagrams in the current area provided that the Name to Menu option 
is selected for each diagram. A checkmark beside the diagram name means that the diagram is open. These 
diagrams are selected by the operator from the Diagram menu of Supervise. 
 
To define a diagram: 
 

Step Action 

1 Select Diagram → Create.  

2 Define how you want to display the diagram (see “The Definition of New 
Diagram tab” below). 

3 Assign function keys to the most commonly used operations (see “The 
Function Key Assignment tab” below). 

 
The figure below shows the Definition of New Diagram tab. 

 
 Figure 2.10 On this tab you specify the name of the diagram, include a background picture or color and select 

various display options. 

This tab contains the following important object properties: 
 

Property Description 

Name Enter a unique and descriptive name. 

Name to Menu Select this option if you want to show the diagram name in the 
Diagram menu. 

Diagram 
background  

Diagram menu 

Defining a 
diagram 

The Definition of 
New Diagram tab 
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Background Select Picture to include a background picture from an external 
drawing application. Select Color to include a background color.   

Diagram Type Select reusable diagram if you want to create multiple diagrams 
that are identical with the exception of the underlying process 
components. All the underlying process components will be 
created as a group in the project.  
NOTE: For further information about the group object refer to 
the “The Group Object Type” section. 

Miscellaneous 
display options 

Select the diagram window elements you want to show, for 
example, Title Bar and Status Bar. 

  

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about.   
 
The figure below shows the Function Key Assignment tab. 

 
 Figure 2.11 On this tab you assign function keys to the most frequently used operations. 

This tab contains the following important object properties: 
 

Property Description 

Function Keys Select the function key to which you want to assign an operation. 
NOTE: By default, F1 is used to access Help, but you can 
overwrite it, if required. 

Object Name Select the object that you want the function key to operate on. 

Index Select the atom you want the function key to activate, for 
example, HA (High Alarm) for an analog object.  

Command/Value Select the command you want to execute or the value you want 
to assign to the object when the key is pressed. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about.  
 
  

The Function Key 
Assignment tab 
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The figure below shows an example of a diagram window: 

 
 Figure 2.12  The diagram window shows a section of the monitored process. 

 
 
You can also embed an OLE object as a diagram. This is useful, if you want the operator to open an 
external application simply by choosing that diagram. When the OLE-embedded diagram is opened, all the 
functionality of the server application is available. 
For further information, search for “OLE-embedded diagrams” in the Definition Help file. 
 

The diagram 
window  

OLE-embedded 
diagrams 
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The Graph Object Type 
 
A graph is a graphical chart showing the value or state of one or more process components. The data source 
for a graph can be either log files (*.log) or base class files (*.bcl). A graph can show historical data, current 
data or a combination of both. 
 
Use a graph to achieve the following: 
• a graphical overview of the values and states of related process components 
• detect adverse trends at an early stage 
 
There are three types of graphs: 
• A predefined graph is a graph defined by the system designer which the operator can access from the 

Graph menu or by clicking on a symbol representing the graph. Most of the graph properties cannot be 
changed by the operator during supervision, but he can change certain layout properties. 

• A dynamic graph is a graph created on-the-fly by the operator during supervision. The operator simply 
selects the IGSS objects to include in the graph and then selects Graph → Create Dynamic Graph. This 
function is very useful, if the operator wants to monitor a specific process component before and after an 
intervention. A dynamic graph can be saved as a user-defined graph (*.usr). When re-opened, the graph 
will be dynamically updated. 

• A static graph is a snapshot of a predefined or a dynamic graph that the operator wants to save for 
documentation purposes. A static graph can be saved as a graph file (*.gph). When re-opened, the graph 
can be shown, but not updated. 

 
The graph values can be exported to a comma-separated values (.csv) file. The values can then be further 
processed in another program, for example, MS Excel. 
 
The Graph menu shows all available graphs in the currently selected diagram provided that the Name to 
Menu option is selected for each graph. A checkmark beside the graph name means it is open. 
 
 

Step Action 

1 Select Graph → Create.  

2 Define how you want to display the graph (see “The Definition of New Graph 
dialog” below). 

3 Define the graph properties (see “The Define Graph Parameters dialog” below). 

4 Scale and position the resulting graph window. 
 
In this dialog you assign the name and description to the graph and define the window elements you want 
on the graph window. 

 
 Figure 2.13  In this dialog you assign the name and description to the graph and define the window elements 

you want on the graph window. 

Definition 

Use 

Three types of 
graphs 

Export to CSV 

Graph menu 

Defining a graph 
object 

The Definition of 
New Graph dialog  
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This dialog contains the following important object properties: 
 

Property Description 

Name Type a unique and descriptive name. 

Name to Menu Check this box to show the graph name in the Graph menu.  

Miscellaneous 
display options 

Select the graph window elements you want to show, for example, 
Title Bar and Status Bar. 

The figure below shows the Define Graph Parameters dialog. 

 
 Figure 2.14 In this dialog you define which objects you want to represent in the graph, the scaling of the axes, 

colors and various other properties. 

The dialog contains the following important object properties: 
 

Property Description 

Start offset Specify the offset from the current time with which you want the 
graph to start. 

Source Choose either *.log files or *.bcl files as the data source for the 
graph. 

Object Name Select the name of the object you want to show in the graph. 

Atom 
(log data only) 

Select the name of the object atom you want to show, for 
example, PV for the process value of an analog object.  

Reduction 
(BCL data only) 

Select the relevant reduction method, for example, MV to show 
the average value. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about.  
 

The Define Graph 
Parameters dialog 
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The figure below shows an example of a graph window. 

 
Figure 2.15  The graph window shows values or states of multiple process components. 

The Analog Object Type 
 
An analog type in the IGSS system is used to represent a process component that can take on any value 
within a specified range. Analog objects can include two sets of alarm limits and a set point. 
 
The following examples show what analog objects may be used for: 
• a level gauge measuring the contents of a tank in litres. When the tank is empty, it contains 0 litres and 

when full it holds 520 litres. This would mean that the analog IGSS object would have a specified range 
of 0 to, for example, 550 litres. 

• a temperature gauge measuring room temperature within the limits -5 to 35 ºC (used in the following 
example). 

 
To define an analog object: 
NOTE: The following procedure describes how you define an analog object using standard symbols. You 
may want to use alternative display types, for example, a bar display or a circular display. For further 
information, search for “bar displays” or “circular displays” in the Definition Help file. 
 

Step Action 

1 Select Objects → Analog Elements. The Object Browser dialog appears.  

2 Type a unique name and an optional description, select the area Global in the 
Tree-view, and then click Create. The analog object properties dialog appears. 

3 Specify the measuring range, low and high alarm limits, number of decimals, 
etc. (see “The Analog tab” below). 

4 Specify how you want to collect and log your data (see “The Data 
Management Definitions tab” below). 

5 Specify what you want to show along with the symbol of the process 
component (see “The Display tab” below). 

6 Specify the PLC address of the process component and attach alarm texts 
(see “The Edit Mapping tab” below). 

7 Choose the symbol you want to represent the process component (see “The 
Symbol Definition tab” below) and click OK. The object symbol and caption 
appear.  

8 Position the object symbol and caption on the diagram. 
 

The figure below shows the Analog tab: 

The graph window 

Definition 

Use 

Defining an 
analog object 

The Analog tab 
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 Figure 2.16 On this tab you specify the measuring range, the desired process value, unit of measurement, the 

number of decimals and alarm limits. 

This tab contains the following important object properties: 
 

Property Description 

Alarm limits 
 

An analog object has two built-in sets of alarm limits expressing 
varying degrees of seriousness that may be used if relevant - or 
disabled if not required.  
Alarm supervision is enabled simply by checking the box next to the 
desired limit. When enabled, an alarm is generated and shown in the 
Alarm List during supervision when the actual value exceeds or goes 
below the limit. 
TIP: You can easily enable or disable the individual limits on the 
Edit Mapping tab.  

Actual value In this box you can type an initial process value. The value will, of 
course, be updated dynamically during supervision; the value defined 
in Definition is overwritten as soon as the data collection is started. 

Set point The set point is the desired process value, the value according to 
which the process value is calibrated. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about.  
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The figure below shows the Data Management Definitions tab: 

 
 Figure 2.17  On this tab you specify how you want to collect and log data.  

This tab contains the following important object properties: 
  

Property Description 

Scan interval 
 

Decides how often IGSS scans the component address in the PLC (the 
address itself is given on the Edit Mapping tab). In this example, the 
temperature does not change very rapidly, so a scan interval of 30 
seconds (30,000 msec) is selected. Note that if you are using event-
oriented communication, you must select None.   

Logging With the logging buttons, you decide whether you would like the 
system to save the values that are scanned with 30-second intervals for 
this component in the log files. You only need to select logging for the 
process components for which you want to log historical data (for 
example, to be used in graphs). If you do not need logged data for a 
particular component, select None. Note that the buttons have a 
percentage next to them. If you click > 10 %, the system will log all 
changes that are larger than 10 %.  

Base interval Defines how often the system reduces the scanned values to one value 
with the purpose of calculating statistics on the measured values. In 
this example, a base interval of 10 minutes is used which means that 
every 10 minutes, the system will reduce the up to 20 values (with a 
scan interval of 30 seconds) to one value. This reduced, statistically 
calculated value is subsequently used in the operational reports.  

Data reduction Defines how the data is reduced to one value according to the Scan 
interval and Base interval settings. By clicking one or more boxes in 
the Data reduction group, you select which method the system is to 
reduce by: calculate an average, save the smallest or the largest value 
in the 10-minute interval (Min and Max), calculate the sum of the 
values in the 10-minute interval, save the latest value (Actual) or save 
the number of times the process component has changed state 
(Change). Which method you choose will depend on the nature of the 
component. For a temperature measurement, Average is frequently 
selected. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about.  
 
The figure below shows the Display tab: 

Data Management 
Definitions tab 

Display tab 



114 IGSS Getting Started  

 
 Figure 2.18 On this tab you specify what you want to show along with the symbol 

of the process component.  

This tab contains the following important object properties: 
  

Property Description 

Show 
 

Check the relevant items you want to display on the diagram. 

Symbol 
selectable 

Check this box to allow the operator to select the object symbol on 
process diagrams. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about. 
 
On this tab you specify the PLC address of the process component and attach alarm text(s). Note that a full 
PLC address consists of a node number, a data group, a word offset and a bit offset. The figure below shows 
the Edit Mapping tab: 

 
 Figure 2.19 On this tab you specify the PLC address of the process component.  

This tab contains the following important object properties: 

Edit Mapping tab 
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Property Description 

Configure atom Select the atom to which you want to assign a PLC address or an 
alarm text. The number of atoms listed depends on your selections 
on the Analog tab. 

I/O mode Select the relevant input/output mode in the drop-down list. In 
addition to an actual value (Actual Value), this object has also been 
configured with two sets of alarm limits and a set point; as this tab 
reflects the decisions made on the Analog tab, six atoms are listed. 
However, only one address needs to be entered, namely for the 
actual value. This is due to the fact that the limits (high alarm, high 
limit, low alarm and low limit) and the set point are all local to the 
PC system. Other possibilities for the limits and the set point are: in, 
out or in/out in which case PLC addresses should also be given for 
these values. Normally, though, local is preferred. 

Alarm Details Either attach an existing alarm text by selecting it in the drop-down 
list or create a new one by clicking New and then define the alarm 
text properties in the ensuing dialog. 
An alarm number must be given for each alarm limit with alarm 
supervision enabled on the Analog tab.  
To edit an alarm text, select it in the drop-down list, click Edit and 
change the alarm text properties, as required.  
TIP: You can also create and edit alarm texts by selecting Edit → 
Alarm Details. 

Driver Select the relevant PLC driver. The list of drivers corresponds to the 
drivers included in the active driver profile. The drivers are 
configured in Driver Setup.  
TIP: You can select a default driver in the Area Properties dialog.  

Node Enter the relevant node number to identify the PLC. Each PLC has a 
unique number. When there is only one PLC, node number 0 is 
default.  
TIP: You can select a default node in the Area Properties dialog. 

Data Group Enter the relevant data group. This setting identifies a section (data 
group) of the memory layout of the PLC which consists of a number 
of units or blocks of words (16 bit each). 

Word Offset Enter the relevant word offset. This setting identifies the precise 
word within the data group. In this example, data for the temperature 
measurement is read from PLC number 0, from data group number 
20 and from word number 16 within that block. 
NOTE: The system will always write one data word (that is, 16 bits) 
at a time. The sending of a command means that the 16 bits are sent 
to the PLC, even if only one or two bits have been defined as 
command bits.  

Bit Offset Enter the relevant bit offset. This setting identifies the precise bit 
within the word of the data group. 

External Type The last bit of information the system needs is the external data type 
in the PLC. Clicking the field will open a list of the data types 
available for the selected PLC driver. In this example, FP16 (Fixed 
Point 16 bit) is selected. Please refer to the relevant driver manual for 
details. The external types are enabled or disabled in Driver Setup. 

 

NOTE: Dependent on the PLC driver used, the text labels of the Data Group, Word Offset and Bit Offset 
fields may be replaced by driver-specific terminology. However, if you want to show the default 
terminology, hold down CTRL while you select the driver name.     
For further details about driver configuration, refer to the Driver Setup Help file. 
For further details about alarm texts, search for “alarm texts” in the Definition Help file.  
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The figure below shows the Symbol Definition tab: 

 
 Figure 2.20 On this tab you select the symbol you want to represent the process component.  

This tab contains the following important object properties: 
 

Property Description 

Symbol color Select the color of the symbol.  

Symbol 
angle 

Select an angle if you want to rotate the selected symbol. 

Symbol table Select one of the symbol tables from the drop-down list. The table 
names can be edited in Symbol Editor. 
NOTE: IGSS automatically selects the relevant symbol table for the 
object type you are currently defining. 

Symbol 
preview 

Select the symbol you want to use. This field shows the symbols of the 
currently selected symbol table. 

 

For an explanation of the individual items in the dialog, click the  in the upper right hand corner of the 
dialog, then click the item you want information about.  
 

The Table Object Type 
 
A table object, as is the case for an analog object, is used to represent a process component that can take on 
any value within a specified range. However, a single table object may be used for up to ten analog objects 
that belong together in some way. 
  

Symbol Definition 
tab 

Definition 
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The following examples show what table objects may be used for: 
• temperature gauges placed at different levels in a tank. Being placed at different levels, the gauges 

would probably give different measurements but it would still be interesting to see their values 
presented together. Their values might be temperatures within a range of say -3 to 40 ºC. 

• the oxygen uptake in a tank monitored at four different locations (used in the following example).  
 
You should use a table object: 
• when you have multiple analog objects that logically belong together and 
• share the same measuring range, alarm limits and alarm texts 
 
A table object has no alarm limits and hence no alarm supervision. However, this may be avoided by 
creating an analog object that defines the alarm limits for the table object. The analog object is then 
connected to the table object by selecting the name of the analog object in the Connect To drop-down list on 
the Data Management Definitions tab.  
For further details about inheriting alarm limits, search for “table objects” in the Definition Help file. 
 
To define a table object: 
 

Step Action 

1 Select Objects → Tables (Regulator). The Object Browser dialog appears.  

2 Type a unique name and an optional description, select the Global area in the 
Tree-view, then click Create. The table object properties dialog appears. 

3 Specify the constituent analog objects, a minimum and a maximum value, the 
number of decimals and measuring unit (see “The Table tab” below). 

4 Specify how you want to collect and log your data (see “The Data 
Management Definitions tab” below). 

5 Specify what you want to display along with the symbol of the process 
component (see “The Display tab” below). 

6 Specify the PLC address of the table object (see “The Edit Mapping tab” 
below). 

7 Choose the symbol you want to represent the table object (see “The Symbol 
Definition tab” below) and click OK. The object symbol and caption appear.  

8 Position the object symbol and caption on the diagram. 

 
  

Use 

When do I use a 
table object? 

Inheriting alarm 
limits 

Defining a table 
object 
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The figure below shows the Table tab: 

 
 Figure 2.21 On this tab you specify the constituent analog objects, a minimum and a maximum value, the 

number of decimals and measuring unit.  

 
This tab contains the following important object properties: 
 

Property Description 

Name/Value In this example, the oxygen uptake in a tank is monitored at four 
different locations and the results are shown in a table as the values o1, 
o2, o3 and o4. 

Type The values in the table are presented as fixed values with a fixed number 
of decimals (Fixed Table).  
You may choose to have the values in the table represented as floating 
points instead (Float Table) in which case the values would be 
represented as, for example, 7.00000e+000. 

Decimal 
Point 

Type the desired number of decimals in the box.  

Minimum 
value 

Enter a minimum value for the object. 

Maximum 
value 

Enter a maximum value for the object. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about. 
 
On this tab you specify how you want to collect and log data. This tab is identical to the one for analog 
objects. In this example, we have chosen to scan every 30 seconds (the oxygen uptake does not change 
suddenly) and to save all scanned values in the system's log files. Statistics - in the form of an average value 
- is calculated every 10 minutes. 
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify what you want show to along with the symbol of the process component. The tab is 
identical to the one for analog objects.  
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify the PLC address of the table object. Note that a full PLC address consists of a node 
number, a data group, a word offset and a bit offset. 
Note also that an external data type must be selected so that the system knows the PLC format of the 
process value. 
NOTE: Although a table object can handle up to ten process values, only one address is given. This is 
because the system assumes that the values have consecutive PLC addresses. 

The Table tab 

The Data 
Management 
Definitions tab 

The Display tab 

The Edit Mapping 
tab 
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For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you select the symbol you want to represent the process component. This tab is identical to the 
one for analog objects, except for the available symbols. 
NOTE: IGSS automatically selects the relevant symbol table for the object type you are currently defining, 
but you are free to choose one of the other symbol tables. 
For further information about this tab, refer to the “The Analog Object Type” section. 
 

The Counter Object Type 
 
A counter object is actually a variation on the standard analog type. Similar to the analog type, a counter 
object may take on any value up to a given maximum. Unlike the analog object type, though, a counter 
object has only one alarm limit. The operator can issue four commands to a counter object: start, stop, reset 
and preset. 
 
A counter object is typically used for counting hours of operation of, for example, a motor to ensure that 
maintenance is performed on time. This use would imply that the PLC program would start the counter 
when the motor starts and stop it when the motor stops. 
 
 

Step Action 

1 Select Objects → Rectangular Field. The Object Browser dialog appears. 
NOTE: A counter object is frequently made as a click-sensitive area, that is, 
an area on the screen merely displaying the name and the value.  

 
When you define a rectangular field, you get a rectangle that you can freely 
position and resize.  

2 In the Tree-view open the Global area, select Counter, type a unique name 
and an optional description, then click Create. The counter object properties 
dialog appears. 

3 Type the alarm limit value and enable alarm supervision and type the preset 
and maximum values  (see “The Counter tab” below). 

4 Specify how you want to collect and log your data (see “The Data 
Management Definitions tab” below). 

5 Specify what you want to show along with the symbol of the counter object 
(see “The Display tab” below). 

6 Specify the PLC address of the counter object and attach the alarm text (see 
“The Edit Mapping tab” below). 

7 Choose the symbol you want to represent the counter object (see “The 
Symbol Definition tab” below) and click OK. The object symbol and caption 
appear.  

8 Position the counter object symbol and caption on the diagram. 
 

 
The figure below shows the Counter tab: 

The Symbol 
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 Figure 2.22 On this tab you specify the preset and maximum values and whether you want to enable alarm 

supervision.  

This tab contains the following important object properties: 
 

Property Description 

Limit Check this box to enable alarm supervision so that an alarm will be 
generated when the limit value is exceeded. 

Preset value Enter the value you want to insert when the operator issues the Preset 
command. 

Maximum 
value 

Enter the maximum value for this object. 

 

NOTE: Seen from the point of view of the system designer, pressing any of the four option buttons 
corresponds to sending a specific bit combination to the PLC. The bit combinations for the four buttons are: 
Start 1000 
Stop 1001 
Reset 1010 
Preset 1011 
 
On this tab you specify how you want to collect and log data. This tab is identical to the one for analog 
objects. In this example, we have chosen to scan every 30 seconds (the motor does not start every other 
second) and we have chosen not to log (None) as we have no wish to see the counter object's historical 
values. We do, however, want to see the object values in the system's operational reports and therefore we 
have told the system to save the process value every half hour (Base interval = 30 and Data reduction = 
Actual). 
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify what you want to show along with the symbol of the counter object. The tab is 
identical to the one for analog objects.  
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify the PLC addresses of the counter object and attach the alarm text for the alarm limit. 
Note that a full PLC address consists of a node number, a data group, a word offset and a bit offset. The 
figure below shows the Edit Mapping tab. 

The Data 
Management 
Definitions tab 

The Display tab 

The Edit Mapping 
tab 



 IGSS Types and Templates 121  

 
 Figure 2.23 On this tab you specify the PLC addresses of the counter object.  

A counter object contains the following atoms: 
 

Select this 
atom … 

and type the following: 

Command the address for the start/stop command that the operator can issue. 

Count the address where IGSS can read the current counter value. 

Limit In this example, we have chosen to use a local alarm limit, that is, an 
alarm limit that exists only in IGSS and has no connection to the PLC. 
You must also attach an alarm text for the counter alarm limit. 

Preset the address to which the preset value is to be sent to when changed by the 
operator. 

 

Note also that an external data type must be selected so that the system knows the PLC format of the 
process value. In this example, select Counter. 
NOTE: For each individual atom (Command, Count, Limit and Preset), you can choose I/O mode, that is, 
whether the system is to read from and/or write to an address in the PLC (i/o, in, out) or whether the value is 
to be internal in the system only (local). 
 
On this tab you select the symbol you want to represent the counter object. This tab is identical to the one 
for analog objects, except for the available symbols. 
NOTE: IGSS automatically selects the relevant symbol table for the object type you are currently defining, 
but you are free to choose one of the other symbol tables. 
For further information about this tab, refer to the “The Analog Object Type” section. 
 

The Digital Object Type 
 
A digital type is used to represent a process component that can take on a finite number of states and 
commands. The operator can issue these commands to change the state of the process component. Usually, 
digital objects are based on digital templates which offer several advantages compared to standard digital 
objects.  
 
Typical uses of digital objects are as follows: 
• a valve that can be either open or closed 
• a motor that can be started, stopped and run at different speeds  
In its most simple form, the IGSS digital type has two states: 0 and 1 and two commands also called 0 and 
1. The figure below shows the Change State tab of the object properties dialog of a standard digital object. 
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 Figure 2.24 The Change State tab of a standard digital object. 

In the dialog as you see it here, you have no possibilities of changing the state and command names or the 
number of states and commands.  
 
The remaining tabs in this dialog are the same as for analog objects. For further information, refer to “The 
Analog Object Type” in this section. 
 
You will hardly ever define an object using the above type but you will practically always use a digital 
template to define the digital object. 
With a digital template you can 
• define exactly the number of states and commands you need 
• give states and commands the names you like 
• specify the valid commands for each state 
• define any number of alarms 
• obtain control right down to the individual bit 
• tailor a template to be used again and again 
For a description of how you define a digital template, refer to “Defining an IGSS Template” in Section B 
of this chapter. 
 
 

The String Object Type 
 
A string object is a text field displaying a message related to the monitored process. 
 
Typically, a string object shows a message when a specific part of the PLC program is running. In the 
following example, the operator will see a message on his screen when the cleaning process is initiated. 
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To define a string object: 
The following procedure assumes that you are using a rectangular field to display the string object. 
Alternatively, you may want to show the string in an Edit box or a text box. For further information, search 
for “standard descriptors” in the Definition Help file 
 

Step Action 

1 Select Objects → Rectangular field. The Object Browser dialog appears. 

2 In the Tree-view open the Global area, select String, type a unique name and 
an optional description, then click Create. The string object properties dialog 
appears. 

3 Specify the text string you want to display and its max. length (see “The 
String Object tab” below). 

4 Specify how you want to collect and log your data (see “The Data 
Management Definitions tab” below). 

5 Specify what you want to display along with the text string (see “The Display 
tab” below). 

6 Specify the PLC address of the string object (see “The Edit Mapping tab” 
below) and click OK. The rectangular field and object caption appear.  

7 Position and resize the rectangular field representing the string object on the 
diagram. 
NOTE: An Attributes of Rectangle tab appears, if you double-click the field 
allowing you to specify the precise co-ordinates, width and height of the 
field.  

 
The figure below shows the String Object tab: 

 
 Figure 2.25 On this tab you specify the text string to be displayed and its max. length.  

This tab contains the following important object properties: 
 

Property Description 

Maximum length Enter the maximum number of characters you need for this text 
string. 
NOTE: You can use up to 70 characters. 

String Enter the text string you want to display. 

 

Defining a string 
object 

The String Object 
tab 
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On this tab you specify how you want to collect and log data. The tab is identical to the one for analog 
objects. 
You may select a scan interval and a log frequency. Note, though, that as it makes no sense to perform any 
statistical calculations on a string, the Data reduction and Base interval options are not selectable. Of 
course, the logged values cannot be presented in graphs as is normally the case, but the log files may be 
displayed and printed. 
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify what you want to show along with the string object. The tab is identical to the one 
for analog objects. For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify the PLC address of the string object. Note that a full PLC address consists of a node 
number, a data group, a word offset and a bit offset. The figure below shows the Edit Mapping tab. 

 
 Figure 2.26 On this tab you specify the PLC address of the string object. 

A PLC address for a string object specifies the beginning of the string. The number of characters defined in 
the Maximum length field on the String Object tab are automatically reserved. Note also that you must select 
an external data type. 
For further information about this tab, refer to the “The Analog Object Type” section. 
For further details about string objects, search for “string objects” in the Definition Help file. 
 
On this tab you can optionally specify the precise co-ordinates, width and height of the rectangular field. 

 
 

The Scaling Object Type 
 
A scaling object maps one set of values to another set of values. Note that a scaling object is an internal 
object and therefore does not represent a physical process component. 
 
Use the scaling object when you need to map one set of values to another, instead of writing the necessary 
PLC code. You can use a scaling object to convert values from one measurement unit to another, for 
example, from °C (Celsius) to °F (Fahrenheit).  
NOTE: You can also define unit conversions without using a scaling object. Search for "Unit Conversion 
dialog" in the Definition Help file. 
To define such a scaling object, refer to “Define Scaling Objects” in Chapter 3. 
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To define a scaling object: 
NOTE: It is recommended to define scaling objects in the Global area to make them globally available in 
the project.  
 

Step Action 

1 Select Objects → New Unreferenced. The Object Browser dialog appears.  

2 In the Tree-view open the Global area, select Scale, type a unique name and 
an optional description, then click Create. The scaling object properties 
dialog appears. 

3 Specify the input/output values (I/O value) and the corresponding values 
(Real value) to which you want to map the original values (See “The Scaling 
Specification tab” below). 

 
The figure below shows the Scaling Specification tab: 

 
 Figure 2.27 On this tab you specify the input/output values (I/O value) and the new values (Real value) to 

which you want to map them.  

This tab contains the following important object properties: 
 

Property Description 

I/O value Enter the input/output values you want to map to another set of values. 

Real value Enter the values you want to use instead of the input/output values. 
 

In this example, the scaling object maps values within the area 4 to 20 onto values in the area 0 to 100. This 
means that when, for instance, the value 12 is sent to IGSS, the scaling object maps the value onto 50. 
 
A scaling object may be used any number of times to scale analog values. To connect a scaling object to an 
analog object: 
 

Step Action 

1. Open the diagram containing the analog object to which you want to connect 
a scaling object. 

2. Double-click the symbol representing the analog object. 

3. Click the Data Management Definitions tab. 

4. In the Scale As field, select the appropriate scaling object in the drop-down 
list which shows all scaling objects in the active project. 

 

The Group Object Type 
 
A Group is a collection of any number of related objects and descriptors that you want to treat as one entity. 
The members of a Group will typically have a number of dependants in the source project. These 

Defining a scaling 
object 

The Scaling 
Specification tab 

Connecting a 
scaling object to 
an analog object 

Definition 
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dependants may be templates, alarm numbers, report formats, VBA code, etc. and they will automatically 
become part of the Group. This makes the Group self-contained allowing you to either copy/paste the 
Group within the current project or export it to a file for import into another project at a later time. 
The group object includes the following features: 
• Copy/paste of Group members into the current project 
• Export/import of Group members into another project 
• User-defined name substitution rules allow fast replication of similar diagrams 
• User-defined address substitution rules allow fast replacement of PLC addresses 
• Groups can be members of other Groups allowing you to build a hierarchy of Groups 
• Linked groups 
The linked groups allow the designer to change the “parent” group and make the changes effective in the 
“child” groups. 
 
The following examples show what the group object may be used for: 
• A production containing two or more identical production lines. 
• A ship containing two or more identical motors requiring the same parameters. 
 
Group objects are often used together with the reusable diagram feature. 
 
To define a group object: 
 

Step Action 

1 Select Edit → Group Manager…. The Group Manager dialog appears. 

2 Click the New Group…. button to create a new group. The Enter Name of 
Group dialog appears. 

3 Enter the name of the group, and click OK. 

4 Select the objects that should be included in the group object. This can be 
done in one of three ways: 
• Click the Browse button, and through the object browser drag and drop 

the objects into the group manager. 
• Click Add Selected Objects, when creating a group in an existing 

diagram. 
• Click Add Selected References, when creating a new diagram. 

5 Specify the settings when pasting new objects on the Paste Options tab 

6 If the group should be available in another project export the group by 
clicking Export…, give the group a descriptive name, the default export 
filename is the group name, and click Ok.  
The group has now been exported. 

7  Click Close to exit the Group Manager dialog. 

Use 

Defining a group 
object 
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Visual Guide to Type-specific Properties 
 
This section is a graphical illustration of the fields and buttons on the tabs containing the type-specific 
properties. 
When you are working with IGSS, we highly recommend that you use the What’s This? Help topics to get 
specific information on the individual item in a dialog. For information on how you use this function, refer 
to the “IGSS User Documentation” section at the beginning of this manual. 
 

 
 
 
 

 
 
 
 
 
 
 

 
 
 

Introduction 

Area 

Diagram 

Graph 

Analog 

Enter a unique name of 
max. 30 characters. Do 
not use spaces in the 
name. 
Enter an optional 
description of max. 254 
characters. 

Check the window elements you want 
to show, for example, the status bar. 

Select Name or Description to show either in 
the title bar of the diagram. 

Displays a preview of the 
selected background 
picture or color. 

Check this box to show 
the diagram name in the 
Diagram menu. 

Check this box before you 
assign function keys on the 
Function Key Assignment 
tab. 

Enter an optional description of 
max. 254 characters. 

Check this box to show 
the area name in the Area 
menu. 

Type the default node number 
identifying the appropriate PLC in 
the network.  This node number is 
automatically suggested for new 
objects you create in this area. 

Enter a unique name of 
max. 30 characters. Do 
not use spaces in the 
name. 

Select a default driver in the drop-
down list. The driver is 
automatically suggested for new 
objects you create in this area. 

Check the window elements 
you want to show, for 
example, the status bar. 

Enter a unique name of max. 
30 characters. Do not use 
spaces in the name. 

Enter an optional description 
of max. 254 characters. 

Check this box to show the 
graph name in the Graph 
menu. 

Check this box to display a 
grid behind the graph. 

Select Name or Description to 
show either of the two in the 
title bar of the graph. 

Select either Picture or Color as 
the background for you diagram. 
Click Browse to find the 
appropriate picture or color.  

Optionally, protect this area by 
attaching a Protect object. If the 
current user owns the user 
privileges of the Protect object, he 
gains access to this area. 

Optionally, protect this 
diagram by attaching a 
Protect object. If the current 
user owns the user privileges 
of the Protect object, he 
gains access to this diagram. 
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Table 

Counter 

Digital 

Enter the min. value of the 
object. 

Enter a unique name of 
max. 30 characters. Do not 
use spaces in the name. 

Enter the max. value of the 
object. 

Enter the two high alarm limits. 

Enter an optional description 
of max. 254 characters. 

Enter a unique name of 
max. 30 characters. Do not 
use spaces in the name. 

Enter the names of the 
individual analog objects 
(max. 10). 

Enter an optional 
description of max. 254 
characters. 

Enter the initial values of the 
individual entries. 

Enter the max. value of the 
analog object. 

Enter a unique name of 
max. 30 characters. Do not 
use spaces in the name. 

Enter the min. value of the 
analog object. 

Enter an optional description 
of max. 254 characters. 

Enter the desired 
measuring unit. 

Shows the actual value of 
the counter object. 

Check this box to generate an 
alarm when the limit is 
exceeded. 

Enter a unique name of 
max. 30 characters. Do not 
use spaces in the name. 

Shows the four commands 
available to the operator 
during supervision. 

Enter the default value you 
want to insert when the 
operator selects Preset. 

Enter the max. value of the 
object. 

Enter the desired number of 
decimals. 
Enter the desired unit. 

Check this box to generate an 
alarm when the actual value 
exceeds the limit. 

Move the horizontal lines to change the values for the 
alarm limits, set point, etc. Use the color coding to 
determine which line to move. The corresponding value 
will change when you move the line. 

Check this box to generate 
an alarm when the actual 
value falls below the limit. 

Shows the process value 
during supervision. 

Enter the desired process 
value. 

Select the type of table you 
want. 

Enter the two low alarm limits. 

Enter the desired number 
of decimals. 

Enter the desired measuring 
unit. 

Click the States and 
Commands tab to specify 
state and command names. 

Shows the name of the digital 
template. 

Define the use of the 
individual bits in the byte sent 
from the PLC to the PC. 

Define the use of the individual 
bits in the byte sent from the 
PC to the PLC. 

Shows an explanation of the 
characters used to define how 
each bit is used. 

Shows the optional 
description. 

Check the relevant boxes to define 
whether the 32 bits are to be interpreted 
individually or in combination. 
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String 

Scaling 

Enter an optional description 
of max. 254 characters. 

Enter the text string you want 
to show. 

Enter the max. length of the 
text string. 

Enter a unique name of 
max. 30 characters. Do not 
use spaces in the name. 

Enter an optional 
description of max. 254 
characters. 

Enter a range of incoming 
values, for example, from 4 
to 10. Max. 10 values may 
be given. 

Enter a range of real 
values, for example, from 0 
to 100 to which you want to 
map the I/O values. Max. 
10 values may be given. 
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Section B: IGSS Templates 

 
This section contains the following information: 
• A description of what a template is and what it is used for 
• An example where we define a digital template 
 
This chapter contains the following topics. 
 
What Is an IGSS Template? ...............................................................................................131 
Defining an IGSS Template ...............................................................................................131 
 
 

About this section 

Contents 
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What Is an IGSS Template? 
 
An IGSS template is a customized template - based on one of the IGSS object types - that the user creates 
when a number of process components are very similar and share several properties. The real process 
components are then defined using the template, thus eliminating the repetitive task of entering the same 
information for each component. In fact, the user only has to enter a unique name and a specific PLC 
address to make a new component based on a template. 
 
There are several reasons why you should use templates extensively: 
• They ensure consistency within a project for process components based on common templates. 
• They save valuable engineering time by eliminating the need of entering the same information for a 

number of very similar process components. 
• They limit the task of creating new process components to entering a unique name and a specific PLC 

address. 
• They facilitate making changes to multiple objects at a time, simply by changing the template properties. 
 
Templates may be defined for the following object types:  
• Analog 
• Table 
• Counter 
• Digital 
The digital templates are the most widely used templates. The main difference between the digital templates 
and the other template types is that you gain control right down to the individual bit sent to and from IGSS. 
For an example of how you define a digital template, refer to “Defining an IGSS Template” in this section. 
 
A few templates are included for your convenience, for example, the PROTECT template which is a template 
defining protection levels to be used in connection with the User Administration module. If required, you 
may define new Protect objects based on the PROTECT template. 
 
You have 16 different temperature gauges in your plant that all 
• measure temperatures in the range -5 to 35 ºC    
• share the same alarm limits 
• share the same alarm texts  
• have their current process value scanned every 10 seconds 
• must be included in the operational reports 
This would mean that it would make perfect sense to make a template including all these properties and 
then use this template to define each of the temperature gauges T1 to T16. The only two properties that 
would be different in these 16 components would be their name and their specific PLC addresses. 
 

Defining an IGSS Template 
 
In the following example we will define a pump template, PUMP_3. The pump template will have the 
following states and commands: 
 

This command … Results in this state … 

STOP OFF 

SLOW SLOW 

MEDIUM MEDIUM 

FAST FAST 
 

Definition 

Why use 
templates? 

Four types of 
templates 

Built-in templates 

Example: An 
analog template 

This example 
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By defining a digital template you can: 
• define exactly the number of states and commands you need 
• give states and commands the names you like 
• define any number of alarms 
• obtain control right down to the individual bit 
• tailor a template to be used again and again 
Usually, you will define one template for each type of valve, motor, pump, etc. If you need two templates 
for two different types of pumps, simply copy the first template (select Template → Create Template) and 
use the Copy From function, make the necessary adjustments and give it a new name, for example, 
PUMP_2. 
 

Step Action 

1. Select Template → Create Template. The Create Template dialog appears. 

2. In the Type group, select Digital and type a unique name for the template (in 
this case, PUMP_3) and click OK. The digital template properties dialog 
appears. 
NOTE: To easily distinguish the names of templates and process 
components, we recommend that you use ALL CAPS for template names and 
normal case for process components. 

3. Define the bits used for states and commands (see “The Bit Map I/O tab” 
below). 

4. Define the bits used for alarm indication and alarm acknowledgement (see 
“The Alarm In/Ack Bit tab” below). 

5. Assign names to the individual states and commands (see “The States and 
Commands tab” below). 

6. Define the default command and valid commands for each state (see “The 
Command/State Config tab” below). 

7. Specify how you want to collect and log your data (see “The Data 
Management Definitions tab” below). 

8. Specify the parts of the PLC address which are common to all process 
components you are going to base on this template (see “The Edit Mapping 
tab” below). 

9. Choose a color and symbol for each state (see “The Symbol Definition tab” 
below). 

10. Click OK to save the template. 
RESULT: The template is now ready for use. For an example where we use 
a template to define a process component, refer to “Define Digital templates” 
in Chapter 3. 

 
  

Advantages of 
using a digital 
template 

Defining a digital 
template 
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The figure below shows the Bit Map I/O tab: 

 
Figure 2.28 On this tab you specify how you want to use the individual bits sent to and from IGSS. 

This tab contains the following important object properties: 
 

Property Description 

To PC 
(State) 

Define how you want to use the individual bits communicated from the 
PLC to IGSS. You have 32 bits for state and command indicators.  
In the example, bits 0 and 1 are used as state bits. The symbols are 
described in the LEGEND. 

From PC 
(Command) 

Define how you want to use the command bits sent from IGSS to the PLC. 
Here two command bits are used. Similar to the two bits used for states, 
two bits give you the opportunity to name four commands. The four 
commands represent the four bit combinations: 00. 01, 10, 11. 

 

For an explanation of the remaining items, click the  in the upper right hand corner of the dialog, then 
click the item you want information about.  
 
The figure below shows the Alarm In/Ack Bit tab: 

 
Figure 2.29 On this tab you specify the alarm indication and alarm acknowledgement bits sent to and from IGSS. 

 
  

The Bit Map I/O 
tab 

The Alarm In/Ack 
Bit tab 
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This tab contains the following important object properties: 
 

Property Description 

To PC 
 

Define the alarm indication or alarm acknowledgement bits communicated 
from the PLC to IGSS.  
In the example, bit 0 is used as an alarm indication bit (+) and 1 as an 
alarm acknowledgement bit (*). 

From PC 
 

Define the alarm acknowledgement bit communicated from IGSS to the 
PLC.  
In the example, bit 0 is used as an alarm acknowledgement bit (*).  

 

TIP: It is recommended to set an acknowledgement bit both To PC and From PC. This ensures that the 
operator acknowledgement is sent to the PLC and that IGSS gets an acknowledgement back from the PLC. 
If you only set it From PC, you cannot be sure that the PLC has received the bit.   
For details about alarm indication and acknowledgement bits, search for “alarms” in the Definition Help 
file. 
 
The figure below shows the States and Commands tab: 

 
Figure 2.30 On this tab you specify the names of the states and commands of the digital template. 

This tab contains the following important object properties: 
NOTE: The number of states and commands is determined by the number of state and command bits 
defined on the Bit Map I/O tab. 
 

Property Description 

Add State Renames the selected state in the list box with the state name you 
enter or select. You can either enter a new state name or select 
existing states by opening the drop-down list. 

Add Command Renames the selected command with the command name you enter 
or select. You can either enter a new command name or select 
existing commands by opening the drop-down list. 

 

 
On this tab you specify how you want to collect and log data. This tab is identical to the one for analog 
objects. In this example, we will choose Logging Out, because we want every command that the operator 
issues to be registered in the system’s log files. We will choose > 0 % because we want to log all state 
changes. Every five minutes the system saves the number of state changes in the .bcl files (the data 
reduction method Change is selected). These values are later used in the calculation of the values for the 
operational reports. 
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you specify the PLC address of the process component. Note that a full PLC address consists of 
a node number, a data group, a word offset and a bit offset. 

The States and 
Commands tab 

The Data 
Management 
Definitions tab 

The Edit Mapping 
tab 
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NOTE: Remember that we are defining a template and therefore we will not specify a specific PLC 
address. What we can do, though, is to specify the node number and the data group but leave the specific 
word and bit offset open to be defined for the individual objects when they are subsequently defined. 
Specifying alarm texts poses no problem - all components that will later share this template will all share 
the same alarm texts. 
For further information about this tab, refer to the “The Analog Object Type” section. 
 
On this tab you select a color and a symbol for each state of the digital object. This tab is identical to the 
one for analog objects, except for the available symbols. 
By checking the Copy symbols to template box, you save all the color and symbol selections as part of the 
template. When you later define new objects based on this template, you can import these selections by 
clicking the Copy Symbols From Template button.  
For further information about this tab, refer to the “The Analog Object Type” section. 
 
There are a number of other possibilities in the dialog that we will not describe in detail here: 
• you may choose to look at the bit used for, for example, states as a single, individual bit, or “un-coded” 

as some would have it, rather than as a bit combination. Looking at two state bits individually would 
give three states rather than four, that is, one state for each bit and the common zero state when all bits 
are set to 0. 

• you may choose to have the system automatically give alarm numbers consecutively rather than select 
numbers yourself. 

• you may choose to use inverse logic so that 0 rather than 1 means that a bit is set high while 1 means 
that it is not set. 

For further details about advanced template options, search for “digital templates” in the Definition Help 
file. 

The Symbol 
Definition tab 

Advanced options 
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Glossary 

Term/abbreviation Definition 

actual value The actual value is the current process value of an analog object. 

alarm An alarm is a notification which is generated when an error 
situation occurs, for example, when a value falls below or 
exceeds a certain limit. 

alarm acknowledgement indicator The alarm acknowledgement indicator is a specific bit indicating 
that an alarm has been acknowledged. The alarm 
acknowledgement indicator bit is defined as part of the digital 
template. 

alarm delay The alarm delay is a time delay specifying how long an alarm 
must exist before being registered as such. The default alarm 
delay is specified in the System Configuration module. 

alarm icon The alarm icon shows the total number of active alarms and the 
color of the alarm with the highest priority. Double-clicking the 
alarm icon will open the Alarm module. The alarm icon is also 
shown in the Windows System Tray (lower right corner of the 
Windows Taskbar). 

alarm indicator An alarm indicator is a specific bit defined to indicate incoming 
alarms from a digital object. The alarm indicator bit is defined as 
part of the digital template. 

alarm priority The alarm priority describes the seriousness of the alarm. The 
priority is a value within the range from 255 (highest priority) to 
1 (lowest priority). Each alarm priority should be associated with 
a specific color. 
We recommend that you carefully plan the number of alarm 
priorities and their associated colors to avoid any confusion for 
the operators. 

Alarm module The Alarm module is opened by double-clicking on the alarm 
icon. 
The Alarm module allows the operator to view active and 
historical alarms. The operator can acknowledge alarms and 
make alarm notes which will be visible for all other operators in a 
multi-user system. 

alarm text An alarm text is a general description of an error situation, for 
example, "motor overheated". An alarm text consists of the 
following components: an alarm number, an alarm priority, a 
short alarm text and the operator instructions. 
 
A number of additional properties can be set, including sound and 
events to occur when the alarm arises. 

analog object An analog object is a process component that can take on any 
value within a specified range. Typical examples of analog 
objects are flow meters, level and temperature gauges. 

area An area is a collection of diagrams, graphs and process 
components that belong together. Areas may be used to reflect 
the division of a plant into different logical sections. If a plant 
cannot be seen as divided into different sections, the system 
designer may use only one area. 
 
When you define an IGSS object, you specify which area of the 
project it belongs to. However, one area is special because all 
objects defined here are automatically known in all other areas. 
This area is called ‘Global’ and is automatically created in every 
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IGSS project. Do not rename or remove the Global area. 

atom An atom corresponds to a potential PLC address. 
As an example an analog object has 6 atoms attached, i.e. 6 
entities that might have an address in the PLC: high alarm, high 
limit, actual value, set point, low limit and low alarm. 

background picture A background picture is a drawing used as the static background 
for a process diagram. 
As an alternative, you can also use a background color and create 
the diagram from scratch using the built-in drawing tools. 

bar display A bar display is way of visualizing the process value of analog or 
table objects in a bar graph. A typical example of use is to show 
the water level in a tank. 

base class file (BCL file) Base class files hold historical data processed by the system on 
the basis of the seven built-in data reduction formulas (Average, 
Minimum, Maximum, Sum, Actual, Change and Difference). 
The basis for the calculations made by the system are the data 
scanned in from the PLC at the specified scan intervals. 
There are four intervals with which calculations may be made; 
the intervals may be changed in the System Configuration 
module. Each interval is called a ‘base class’ and result in a 
separate file. 
The lowest base class (the lowest calculation interval) is called 
base class 2 and the highest is called base class 5. 
Examples of file names (GxYYMMDD.bcl):  
G2970128.bcl 
G3970128.bcl 
G4970128.bcl 
G5970128.bcl 
The second character in the file name is the base class, the 
ensuing six characters form the date when the files were created 
and the extension is an abbreviation of ‘base class’. 
When all four calculation intervals are used in a project, there 
will be four files for each day. 
The base class files are located in the project's report folder. 

base interval The base interval determines how often the system reduces the 
scanned values read from the PLC to one data reduction value, 
for example, average. See also "data reduction". 

bit offset A bit offset is a number identifying the precise bit within the 
word of the data group. The bit offset is defined as part of the 
PLC address. 

bitmap file (BMP) A bitmap file is a graphic saved in the *.bmp format. It can be 
used as the background picture of a diagram, as an independent 
graphic or to represent an IGSS object. 

click-sensitive area A click-sensitive area is a field on a diagram on which the 
operator can click to open an IGSS object. A click-sensitive area 
is defined as a rectangular field in IGSS. A typical example is to 
use rectangular fields on an overview diagram where the operator 
simply clicks on the field to open the relevant sub-diagrams. 

command A command is a named command that the operator can issue to 
control a digital object. For example, an "open" command to open 
a valve and a "close" command to close it. Command names are 
defined as part of the digital template. 

project A project is a model of an actual process being monitored and 
controlled; the process may be anything from a purification plant 
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to a luxury liner or a production line. 
A project consists of a number of process diagrams with dynamic 
representations of the process components (the valves, motors, 
flow meters, etc.) that the operator can control from his screen. 

context-sensitive Help Context-sensitive Help is a Help text describing the specific user 
interface object from which you requested help. In dialogues, 
context-sensitive Help is called What's This Help. 

counter object A counter object is a process component that can take on any 
value up to a given maximum limit. Typically a counter object is 
used to visualise a PLC counter, for example, one that counts the 
hours of operation of a motor. 

data collection (DC) The data collection engine (DC.exe) is the heart of IGSS. DC 
collects data from the process and sends data back to the process, 
for example, if the operator issues a command to stop a pump. 
DC also writes data to the .log, .bcl and .alm data files and 
distributes data to the operator stations in a multi-user system.  
In the System Configuration module, you can control various 
data collection settings. 

data group A data group is a number identifying a section of the memory 
layout of the PLC which consists of a number of units or blocks 
of words (16 bit each) numbered from 0 to 256. The data group is 
specified as part of the PLC address. 

data reduction Data reduction defines the method used to reduce the scanned 
process values to one data reduction value, for example, average. 
The scan interval defines the interval between the individual 
readings of the process values and the base interval defines the 
interval between the individual reductions. 

Definition The system designer's main module in IGSS. This is where you 
build the project that the operator should be able to monitor in the 
Supervise module. 

diagram A process diagram is a graphical view of a process or part of a 
process. A diagram typically consists of a static and a dynamic 
part. The static part comprises the process pipes, the tanks, etc. 
while the dynamic part shows the contents of the tank, the valves, 
the motors, etc. that change state or value.  
A diagram may be opened from the Diagram menu, from a click-
sensitive area, from a symbol or using a function key. 

digital object A digital object is a process component that has a finite number 
of states and commands. Typical examples are valves, motors and 
pumps. 

driver A driver is a control program enabling IGSS to communicate 
with the PLC or other data collection device which collects the 
data from the process. 7-Technologies has developed a wide 
range of communication drivers, but you can also use the generic 
driver based on the OPC (OLE for Process Control) standard. 

enhanced metafile (EMF) An enhanced metafile is a graphic saved in the .emf format. It can 
be used as the background picture of a diagram, as an 
independent graphic or to represent an IGSS object. 

external type The external type identifies the data type used in the PLC to 
represent the process value. When IGSS knows this format, it 
automatically converts the value to normal integers. 
The available data types are driver-specific and can be enabled or 
disabled in the System Configuration module. 
 
Examples of external types are: FP8 (fixed point 8 bit), FP16 
(fixed point 16 bit) and FP32 (fixed point 32 bit). 
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function key A function key is one of the F-keys on the keyboard. In IGSS you 
can assign frequently used operations to function keys. Function 
keys are defined as part of the diagram properties, for example, 
F2 to start the pump and F3 to stop it. 
 
Up to 24 function keys can be defined for each diagram. 
Additionally, 24 global function keys can be defined. A prefix 
key is used to activate function keys 13 - 24. 

Global area The Global area is a special area. All objects defined in this area 
are automatically known in all areas. The Global area is 
automatically created in an IGSS project. Do not rename or 
remove this area. 
 
We recommend that you define templates and scaling objects in 
the Global area to make them globally available in the project. 

global parameter A global parameter defines a global setting for IGSS, for 
example, data management and data collection settings. The 
global parameters are configured in the System Configuration 
module. 

graph A graph is a graphical chart showing the values or states of a set 
of process components. The source data can be either log data 
(.log files) or reduced values (.bcl files). 

grid A grid consists of two sets of lines that crisscross at right angles. 
On a diagram there is an invisible grid of horizontal and vertical 
dots. In IGSS you can set the grid size (in mm) and snap objects 
to that grid to easily align objects. 

I/O mode The I/O mode defines whether the value is read from (in) or 
written (out) to a PLC address or both (in/out).  Some values can 
be set to "local" if they are generated within IGSS. This is 
typically used for alarm limits on analog objects. IGSS detects 
when the process value exceeds the specified alarm limit and 
generates an alarm. 

I/O value (scaling object) The I/O value is a value that IGSS can convert to another value 
(see "real value"), for example, to convert from one measuring 
unit to another. 

IGSS Interactive Graphical SCADA System 

initial display The initial display is the start-up view that the operator will see 
when he starts the Supervise module. The system designer 
chooses the initial display in the Definition module.  
 
The system designer should define an initial display for each area 
of the project. Forgetting to do so will result in a blank screen 
when the operator opens the area in the project. 

installation When a project has been created in the Definition module, the 
system must check it for consistency and completeness. This is 
done using the "Install Project" command in the File menu. 
 
If the project is running when the system designer chooses to 
install the project in the Definition module, he is prompted to 
temporarily stop the project. After installation, the project can be 
started again. 

Job Scheduler Job Scheduler allows you to define and maintain a set of jobs or 
events that need to be automatically executed either at a given 
point in time or at a specified frequency. You can use it to run a 
program or to just display a message to remind you of something. 
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Keep Window option The Keep Window option ensures that a particular diagram is 
always kept open. During supervision four diagrams may be open 
simultaneously. When diagram number five is opened, the first 
one closes unless you have enabled the Keep Window option. 
The option is a diagram property. 

Library toolbar The Library toolbar allows you to place your favourite graphics 
and multimedia files and IGSS objects represented by symbols on 
a floating toolbar. You simply drag the objects to the toolbar and 
when you need to use them again, you drag them onto the process 
diagram. 

local Local is the I/O mode used for atoms which are generated locally 
within IGSS, for example, an alarm which is generated when the 
process value exceeds the alarm limit. 

log file A log file can contain process values, digital states, operator 
commands and login/logout information. Process values and 
states are logged according to the logging deadband selected on 
the "Data Management Definitions" tab. For example, if you 
specify > 5% a scanned value will not be logged until it deviates 
with more than 5% from the previous logged value. To log 
operator commands, select the "Out" check box. 
 
The log files are located in the project's report folder and are 
named 
(YYMMDDHH.log): 
 
01112708.log 
01112709.log 
01112710.log 
 
There is one log file for each hour in which the data collection is 
active. The log data can be used as the basis for graphs. The log 
data can be viewed via the ODBC interface. 

node A node is a unique number identifying the PLC in a network. The 
node number is defined in the System Configuration module. 
 
When you define an object in the Definition module, the node 
numbers defined in System Configuration can be selected as 
part of the PLC address. 
 
TIP: You can define a default node number for each area in the 
project. The node number will then be suggested automatically 
for each object you create in this area. 

object caption An object caption is the text(s) describing the object. The object 
caption may include the object name, object description, the 
current process value and unit. What you want to show in the 
object caption is defined on the "Display" tab of the object 
properties dialogue. 

OLE Linking and Embedding (OLE) OLE is a standard used for linking or embedding components 
made in third party programs into IGSS. You can, for example, 
define an OLE-embedded diagram that refers to an MS Excel 
worksheet that the operators can view during supervision. Note 
that the functions of the OLE server program become available as 
soon as you activate such a diagram. 

operator The operator is the person who monitors and controls the 
monitored process. He will typically only use the Supervise and 
Alarm modules. These two modules are designed to make the 
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monitoring task very easy and straightforward for the operator. 

periodical report A periodical report is a report generated by the operator during 
supervision of the plant. It is based on the historical data 
generated by IGSS. A periodical report can cover five standard 
periods: daily, weekly, monthly, quarterly and yearly. The system 
designer can define a number of report formats that the operator 
can choose between during supervision. 

PLC Programmable Logic Controller 

PLC address The PLC address is a unique address used to enable 
communication with the individual process components. A PLC 
address may hold current process values, states, commands, 
alarms, etc. A PLC address consists of a node number, a data 
group, a word offset and a bit offset. The address is specified on 
the Edit Mapping tab of the object properties dialogue. 

predefined graph A predefined graph is a graph defined by the system designer in 
the Definition module. The system designer can choose to 
include the graph name in the Graph menu, embed the graph on a 
diagram or create a link to the graph. 
 
During supervision, the operator will typically choose the 
predefined graph in the Graph menu. 

preset value The preset value is a value that the operator can issue for a 
counter object with the Preset command from the Supervise 
module. 

process component A process component is a physical process component in the 
plant, for example, a motor, a pump, a valve, etc. 

properties The properties are the attributes or characteristics of an object. 
The object properties are defined and edited from a dialogue 
containing all object properties. For example, to edit the 
properties of an analog object, simply double-click the object 
symbol and edit the properties as required. 

Protect object The Protect object is automatically included in every IGSS 
project you create. It is used to protect IGSS objects from 
unauthorized use. By connecting the Protect object to an IGSS 
object, you can control what the operator is allowed to do with 
this object. The user privileges are set up in the User 
Administration module. 
 
Example: By connecting the Protect object to an analog object 
and by setting up the necessary parameters in the User 
Administration module, you can allow some operators to change 
the set point for the object and other operators will not be able to 
do it. 

PROTECT template The PROTECT template is a built-in template defining protection 
levels. By default, one object called "Protect" is based on this 
template and will be included in every IGSS project you create. If 
required, you can create additional "Protect" objects based on this 
template. 

real value (scaling object) The real value is the value you want to use instead of the I/O 
value, see "I/O value (scaling object)", for example, to convert 
from one measuring unit to another. 

reference A reference is a link to an existing IGSS object. A reference is 
typically used to show an already existing object on another 
diagram. If you copy an IGSS object, you can paste it as a new 
object or as a reference. 

report format A report format is a report template that the system designer can 
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configure in the Definition module. Each report format is 
associated with one of the standard report types in IGSS: 
Periodical report, snapshot report or alarm statistics report 
 
A report format consists of a name, a number of report headings 
and a number of objects from the project. When a report format is 
defined, the operator can choose its name when he wants to 
generate one of the above standard report types. 

right-click menu A right-click menu is a context-sensitive menu which is accessed 
by clicking the right mouse button. The menu gives you access to 
the most frequently used commands associated with the user 
interface element you clicked on. 

SCADA Supervisory Control & Data Acquisition 

scaling object A scaling object is an internal object used to map values from one 
range to values within another range, for example, to convert 
values from one measuring unit to another. A scaling object is 
used to scale analog or table object values. 

scan interval The scan interval defines how often the component address in the 
PLC is scanned. The interval is defined on the Data Management 
Definitions tab of the object properties dialogue. 
 
Four different scan intervals can be selected in the Definition 
module. They are defined in the System Configuration module. 

set point The set point is the desired process value to which the process 
value is calibrated. The set point is defined as part of an analog 
object. The set point value can be changed by the operator during 
supervision. 

simulate To simulate data means to make IGSS use simulated process 
values in the project. This enables the system designer to simulate 
how the operator will view the process during supervision and to 
visually check the diagram layout when the process "comes 
alive".  
 
The data collection engine (DC.exe) must run simulated, if you 
want to use simulated data. The simulation mode is enabled in the 
System Configuration module. 

snap (to grid) Snap to grid means to align an object to the invisible grid of a 
diagram. This function is used to align objects neatly on a process 
diagram. 

snapshot report A snapshot report is a report generated by the operator during 
supervision. It contains the current values from the monitored 
process. The operator can choose to base the snapshot report on a 
predefined report format or simply include all objects from an 
area of the project. 

standard descriptor A standard descriptor is a standard object that you can use to 
represent an IGSS object on a diagram. The standard descriptors 
are divided into the following categories. 
 
{bmc bullet.bmp}  Drawing objects (line, polygon, text, etc.) 
{bmc bullet.bmp}  Windows controls (command button, edit box, 
slider control, etc.) 
{bmc bullet.bmp}  Graphics files (.bmp, .emf, .wmf, .gif, etc.) 
{bmc bullet.bmp}  Multimedia files (.avi and .gif) 
{bmc bullet.bmp}  ActiveX controls and OLE objects 
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Once the standard descriptor is positioned on the diagram, you 
can bind its appearance to the values, states and alarm limits of 
the IGSS object by right-clicking the descriptor and then 
choosing Descriptor Properties in the popup menu. 

state A state is a particular state that a digital object can enter. A valve 
may, for example, enter an "open" or a "closed" state. The 
operator can force a digital object into another state by issuing a 
command. 

state indicator A state indicator is a specific bit representing the state of a digital 
object. The state indicator bit is defined as part of the digital 
template. 

status bar The status bar is the area at the bottom of a window showing the 
current status or giving other information, such as the meaning of 
a particular command. 
 
Note that the diagram status bar contains key information about 
the selected IGSS object, cursor co-ordinates, etc. The diagram 
status bar can be enabled or disabled in the Diagram Properties 
dialogue. 

string object A string object is a text field displaying a message related to the 
monitored process, typically describing that a part of the PLC 
program is operative. An example: "Water is now being filled 
into basin ...". 

Supervise The module used by the operator to supervise and control the 
monitored process. The Supervise module always launches the 
Alarm module to allow operators to continuously monitor the 
alarm state. 

symbol A symbol is a graphic used to represent a process component, for 
example, a valve. Symbols are click-sensitive and during 
supervision open dialogues where the operator can set parameters 
like alarm limits or issue commands like ‘close’. 
 
A standard symbol file (Symbols.v20) containing industry 
standard symbols is supplied with the system. Symbols are pixel-
based and can be created or modified in the Symbol Editor 
program. 

Symbol Editor The program in which the system designer can create new 
symbols or modify the existing symbols in the symbol file. IGSS 
comes with a predefined symbol file, Symbols.v12, which 
contains industry standard symbols that the system designer can 
use immediately.  
 
The appropriate symbol for an IGSS object is applied in the 
object properties dialogue. 

symbol file The symbol file is a library of symbols. IGSS comes with a 
default symbol file, Symbols.v20. The system designer can 
modify or expand this file or create his own symbol file in the 
Symbol Editor program. 

symbol table A symbol table is a collection of symbols for a specific type of 
component. A symbol table may, for example, contain symbols 
for valves. The symbol file contains a number of symbol tables. 
The names of the symbol tables are shown in the lower portion of 
the "Objects" menu in the Definition module. 

symbol table The symbol table is a table containing a group of symbols which 
can be accessed from the Definition module. The default symbol 
file, Symbols.v20, contains a number of tables such as Valves, 
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Graphs, Analog objects, etc. 
 
In the Definition module, the system designer selects the 
symbols from these tables by selecting the appropriate symbol 
table and then selecting the specific symbol he needs. Using the 
Symbol Editor program, the system designer can append his own 
symbol tables to the existing ones. 

system administrator A system administrator is a person who is responsible for 
administering the use of a multi-user system. His duties include 
setting up the user administration, allocating storage space for the 
data files in the system (for example, .log and .bcl files), backing 
up data files before they areremoved from the system and 
administering the network server and operator stations. 

System Configuration The global setup module in IGSS. This is where the IGSS 
servers, operator stations and PLCs are set up by the system 
designer. 

system designer The system designer is the person who builds an image of the 
monitored process and makes sure that data can be received from 
and sent to the process components. The system designer is 
typically a highly skilled engineer who uses a number of Igss 
modules to build the project that the operators will later use when 
monitoring and controlling the plant. The system designer's main 
progam is the Definition module. 

tab A tab is a "page" of a dialogue similar to the index tabs of a card 
file. A tab is accessed by clicking one of the tab names at the top 
of the dialogue. Each tab contains a collection of related 
properties, for example, data management properties. 

table object A table object, like the analog object, is used to represent a 
process component that can take on any value within a specified 
range. However, a single table object may be used for up to ten 
different analog objects that belong together in some way, for 
example, a set of temperature gauges at different locations within 
a tank. 

template A template is a user-defined template - based on one of the IGSS 
types - that you should create when a number of process 
components are very similar and share several properties. The 
real process components are then based on this template 
eliminating the repetitive task of entering the same information 
for each component.  
Templates may be defined for the following IGSS types: analog, 
table, counter and digital. 

type An IGSS type is a built-in template that ensures that you provide 
all the necessary information about each process component you 
define.  
 
There are nine IGSS types:·area, diagram, graph, analog, table, 
counter, digital, string and scaling. Area, diagram and graph are 
non-process objects. The remaining object types represent 
process components, except the scaling object which is an 
internal IGSS object used for conversion purposes. 

UTC Universal Time Coordinated (formerly Greenwich Mean Time), 
used as the basis for calculating time in most parts of the world. 
 
IGSS uses this time format internally. You can switch between 
UTC and local time by enabling or disabling "UTC Date/Time" 
in the "View" menu. 

What's This? Help What's This? Help is a Help text describing a specific item in a 
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dialogue. To view What's This? Help, simply click the "?" in the 
upper right corner of the dialogue, then click the item you want 
information about. 

window element A window element is a part of a window in the Windows 
environment. Window elements include the minimize and 
maximize buttons, the status bar, the title bar, etc. These elements 
can be shown or hidden in diagram and graph windows in IGSS. 

Windows control A Windows control is an item which allows the user to enter 
information, select from a list or issue a command. Windows 
controls include command buttons, combo boxes, list controls, 
sliders, text boxes, etc. 

Windows metafile (WMF) A Windows metafile is a graphic saved in the .wmf format. It can 
be used as the background picture of a diagram, as an 
independent graphic or to represent an IGSS object. 

WinPager WinPager is an add-on utility used to route alarm messages to 
personal pagers, mobile phones, e-mail accounts or telefaxes.  
 
In WinPager, you can set up duty schedules, which define the 
periods where you want WinPager to handle alarms. This would 
typically be evenings or weekends. 
 
Also, WinPager allows for remote acknowledgement of IGSS 
alarms by using a touch-tone telephone or by sending an SMS 
message. 

word offset The word offset is a number identifying the precise word within 
the data group. The word offset is one of the components of a 
PLC address. 
 
"Word offset" is the standard terminology used internally in 
IGSS. For some PLC drivers, this term may be replaced by the 
term relevant for the selected driver. 
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